Datacake Downlink to Chirpstack V4

I am attempting to send a downlink from Datacake to CS V4. I have installed chirpstack-rest-api and configured a downlink in Datacake. I have Datacake configured to send the downlink to http://[IP of my CS Server]:8090. The data send from datacake looks like this:

{"deviceQueueItem": {"confirmed": false, "fPort": 1, "data": "AQAAeA=="}}

I get this response from CS:

{"code":3, "message":"Validation error: FPort must be between 1 - 255", "details":[]}

I would appear that the API is active and parsing the data but for some reason I thinks fport is <1. I assume there is a formatting error in the downlink but based on the V3 API it looks correct to me.

Any hints would be appreciated.

After further testing, this doesn’t seem to have anything to do with Datacake. I pulled the example from the V3 API documentation and ran it on my server with the same result. Here is the command that I used:

curl -X POST --header 'Content-Type: application/json' --header 'Accept: application/json' --header 'Grpc-Metadata-Authorization: Bearer [My Key]' -d '{"deviceQueueItem": {"confirmed": false, "data": "AQID","fPort": 100}}' 'http://localhost:8090/api/devices/A840411BB185E96B/queue'

Which returns this:

{"code":3, "message":"Validation error: FPort must be between 1 - 255", "details":[]}

Interestingly if I run the same command on a V3 server I get this:

{"error":"f_port must be \u003e 0","code":3,"message":"f_port must be \u003e 0","details":[]}

Anything further on this? I’m experiencing similar issues.