Devnonce error in many devices

Hi everyone,
suddenly each device that try again to join my network is not working because of devnonce error. Now I read some previous post and I tried to clear dev nonce in the application server but without success.
I read that it would be possible to do it from database. Now, because I don’t know how to access the correct database and I don’t know sql is there a procedure to solve this issue?
I tried to enter in #postgres and typed :

delete from public.device_activation where (DATE_PART(‘day’, now()) - DATE_PART(‘day’, created_at)) > 100

but nothing.

Please help me, I have almost all the devices ( 10 under my gateway) out of service. I think the others up will stop after battery will be out.

If you know any procedure for newbie, easy to understand, it would be great

Thank you,


i can access to chirpstack_as and chirpstack_ns.
What databaseust be used to type:

delete from public.device_activation where (DATE_PART(‘day’, now()) - DATE_PART(‘day’, created_at)) > 100


I did on both, it looks no error in the database, but nothing change, same error “validate dev-nonce error”

Thank you,

You can do this using the web-interface:

1 Like

Thank you for your answer. I did what you wrote in the previous days, I reset the devices as well, but I had the same error in all the devices.

In the meantime What I did:

In the chirpstack_ns database I TRUNKATED the table public.device_activation bit I still have devnonce error and for the devices deleted and added again I see now first in the device Tab object does not exist and again devnonceerror

Maybe now the table trunkated is corrupted, Idon’t know

Thank you again for your support.
I hope to solve this problem, now 3 gayeways up e many devices don’t work at all

Ok, I isolated the problem: the join failed with errors devnonce is only related to one gateway Mikrotik, I don’t know why. This gateway was the first powered up and as soon as it worked alone there weren’t any issues; aftee powered on 2 more gateways, now the Mikrotik one has this issue to join the devices; same devices when they see the two other gateways they work great

Thank you,