Docker-compose no network-server


I’ve tried setting up the docker-images per instructions here:

The issue I’m facing is that the network-server doesn’t appear to be connectable. I’ve added a new network-server with the hostname:ip of loraserver:8000.

I’ve also tried:

  1. using appserver:8001 but im getting Error context deadline exceeded (code: 2)
  2. using appserver:8000 but im getting Error rpc error: code = Unimplemented desc = unknown service ns.NetworkServer (code: 2)
  3. using localhost:8000 but im getting Error context deadline exceeded (code: 2)
  4. using localhost:8001 but im getting Error context deadline exceeded (code: 2)

I’m assuming that I’ve configured the network-server wrong becuase:

  1. When I try to create a new service-profile or device-profile, I just get a blank screen.
  2. When I tried to add a gateway, there is no Network-server to select.

I’m thinking the problems either lie in:

  1. My entry of loraserver:8000 is wrong for Network-server creation
  2. I should add a bind in my docker-compose config for appserver, but I’m not sure which to add.

Would appreciate any help!

I will update the documentation. For the correct usage see:

Note, in the latest latest version there is an UI bug (regression after upgrading React.js to the latest version). Because of this the create service- and create device-profile screens do not render. This has been fixed and a new latest for the lora-app-server container is currently building. When the new image is available (see Last updated at, you need to do pull the latest images with docker-compose and restart your containers.

Thanks Brocaar! Works now :slightly_smiling_face:

Really appreciate your help!

Great, I’ll close this topic as the issue has been resolved and better documented :slight_smile: