Docker Vs Ubuntu Setup

I am trying to get Chirpstack to work with my gateway hardware. I’ve tried it two ways - one from the Ubuntu setup instructions, and one from the Docker instructions, but I am having issues with each one.
From the Ubuntu setup:
I am able to host the Chirpstack Application Server (although this is somehow separate from the Chirpstack application itself, and I had to change the port from 8080 to 8081, because it would not load in my browser). But the MQTT forwarding does not appear to work, even after registering my gateway on the Network Server, it does not appear to send to the MQTT service. I was unable to successfully set up the Semtech UDP packet forwarding, and the Gateway is not recognized on the UI (says that is has never been seen). Here is my gateway-bridge config output:

**root@xxx:/home/ubuntu# chirpstack-gateway-bridge --config /etc/chirpstack-gateway-bridge/chirpstack-gateway-bridge.toml**
INFO[0000] starting ChirpStack Gateway Bridge            docs="" version=4.0.10
INFO[0000] backend/semtechudp: starting gateway udp listener  addr=""
WARN[0000] [store]    memorystore wiped                  module=mqtt
INFO[0000] integration/mqtt: connected to mqtt broker
INFO[0002] integration/mqtt: subscribing to topic        qos=0 topic="gateway/a84041ffff2662f0/command/#"
WARN[0002] [store]    memorystore del: message 1 not found  module=mqtt
INFO[0002] integration/mqtt: publishing state            gateway_id=a84041ffff2662f0 qos=0 state=conn topic=gateway/a84041ffff2662f0/state/conn
INFO[0024] integration/mqtt: publishing event            event=stats qos=0 topic=gateway/a84041ffff2662f0/event/stats
INFO[0054] integration/mqtt: publishing event            event=stats qos=0 topic=gateway/a84041ffff2662f0/event/stats

I also tried running Chirpstack from the docker. However, I cannot get the application to run in my browser. It simply does not connect. Although I don’t see the Application Server or the Network Server after running the docker. The following is a list of the docker services.

**ubuntu@xxx:~$ sudo docker ps**
CONTAINER ID   IMAGE                                    COMMAND                  CREATED          STATUS          PORTS                                       NAMES
9d287a8072e1   chirpstack/chirpstack-rest-api:4         "/usr/bin/chirpstack…"   17 minutes ago   Up 17 minutes>8090/tcp, :::8090->8090/tcp   chirpstack-docker_chirpstack-rest-api_1
c0e412d91a87   chirpstack/chirpstack:4                  "/usr/bin/chirpstack…"   17 minutes ago   Up 17 minutes>8080/tcp, :::8080->8080/tcp   chirpstack-docker_chirpstack_1
93ee30dba786   chirpstack/chirpstack-gateway-bridge:4   "/usr/bin/chirpstack…"   17 minutes ago   Up 17 minutes>1700/udp, :::1700->1700/udp   chirpstack-docker_chirpstack-gateway-bridge_1
7dd41ab84a01   chirpstack/chirpstack-gateway-bridge:4   "/usr/bin/chirpstack…"   17 minutes ago   Up 17 minutes>3001/tcp, :::3001->3001/tcp   chirpstack-docker_chirpstack-gateway-bridge-basicstation_1
b1bf69968714   redis:7-alpine                           "docker-entrypoint.s…"   17 minutes ago   Up 17 minutes   6379/tcp                                    chirpstack-docker_redis_1
76c328398968   postgres:14-alpine                       "docker-entrypoint.s…"   17 minutes ago   Up 17 minutes   5432/tcp                                    chirpstack-docker_postgres_1
d8f40e7ba6b4   eclipse-mosquitto:2                      "/docker-entrypoint.…"   17 minutes ago   Up 17 minutes>1883/tcp, :::1883->1883/tcp   chirpstack-docker_mosquitto_1

Running the docker produces the following error, when the Gateway appears to try to connect:

chirpstack-gateway-bridge_1               | time="2023-10-18T08:29:16.268624178Z" level=info msg="integration/mqtt: publishing event" event=stats qos=0 topic=us915_1/gateway/a84041ffff2662f0/event/stats
chirpstack_1                              | 2023-10-18T08:29:16.269488Z  INFO chirpstack::gateway::backend::mqtt: Message received from gateway region_config_id="us915_1" topic="us915_1/gateway/a84041ffff2662f0/event/stats" qos=0 json=false
chirpstack_1                              | 2023-10-18T08:29:16.270447Z ERROR chirpstack::uplink::stats: Handle gateway stats error error=Update gateway state

Is somebody able to point me to where this disconnect is occuring and why I am unable to communicate to the server with my gateway and how to get it to show up on the application and the network server?

Thank you very much in advance.

1 Like

With ChirpStack v4, there is no ChirpStack Application Server component. The ChirpStack v4 binary already contains the web-interface. Looking at the Docker services list you shared, ChirpStack v4 is running on port 8080, so that is the port you should use in your browser to open the web-interface.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.