Downlink message enqueued but not sent

I am trying to use the ChirpStack UI (Applications / Devices) to send a downlink message to a specific Class A device. The message is enqueued but never sent. I do receive uplink messages (they can be seen under the “Device data” and “Lorawan frames” tabs) but the server never initiates the downlink message. Can someone explain what am I doing wrong? I am trying to send a simple message (0x5A in hex → Wg== in Base64) to port 200 of the device.

Just in case someone reads my post.
My problem was generated by the fact that the gateway is connected through a 3G mobile network. Restarting the gateway (a Kerlink Wirnet) solved the problem.

1 Like

In that case, ChirpStack probably did try to send it to the gateway, but as no (tx) acknowledgement was received from the gateway, it stayed in the queue.

Yes, that was the case. Sorry for the late reply!

Dear @glederer007 and @brocaar,

I know it has been a while since You have discussed this problem, but now I am facing the same one. As a gateway, I am using Nucleo F746ZG board with LoRaWAN shield and as an end device Nucleo WL55JC1.
Sofar, I have successfully deployed my network on The things network server, but unfortunately was not able to deploy it locally. For this project, I need a local network server and have decided to go with Chirpstack Network server.
After launching the docker image from this link: GitHub - chirpstack/chirpstack-docker: Setup ChirpStack using Docker Compose , I have tried to register my gateway and end device. With the end device, I did not have any problems, but gateway has been acting a bit strange. On the dashboard, it says that the device has never been seen, but it is still receiving uplink messages from my end device.
However, when I try to send some downlinks, they just stack on the enqueue list, but never actually get send away.
To clarify the situation more properly, I am sending some pictures in attachment.

Looking forward to Your answer.

Best regards,

As a gateway, I am using Nucleo F746ZG board with LoRaWAN shield and as an end device Nucleo WL55JC1.

Please note that most likely your issue is caused because you are using a single-channel gateway. I’m not sure if the software on this gateway implements the full Semtech UDP packet-forwarder protocol, most likely there are things missing (e.g. periodic stats, tx acknowledgements, …).

1 Like

@brocaar sorry to brought up this again, I think I’m having a similar problem, is there a way to know if the gateway is sending a tx ack to chirpstack?
From the gateway I noticed that no data is being ack (PUSH_DATA is not being answered by PUSH_ACK) by chirpstack, even though chirpstack is working and receiving data