Downlink mqtt messages Dragino fail


We have a Dragino LT-22222-L that is a lorawan device with Rele, and for make work turning up the rele We have to introduce in queue the code of payload = 0x030100 in hex or in base64 and for turning down We have to introduce 0x030000 and works

but if We try sending a publish mqtt message with the topic (follow documentation):
{“confirmed”:true,“fPort”: 4,“data”:“030100”}

We can see that reach the chirpstack server but nothing happend and doesnot work

and also if why try in Json inside of the web menu queue with format Json:
{“confirmed”:true,“fPort”: 4,“data”:“030100”}

We get message: Exception generated by quickjs: ‘encodeDownlink’ is not defined at (eval_script:164) and also is not working

Why is not working sending a message via mqtt? and why is not working also with the option Json in Queue menu in the web of chirpstack?

Thank you

Hex 0x030000 and string “030000” are not the same.

1 Like

Thank your for your answer, I know, the payload to make change the rele is the 030100 like is in the documentation of the wiki of the device

when I use the this payload in the menu the queue the rele is working

but impossible make work the rele via Mqtt, if We publish message like in the documentation of chirpstack and the brand of dragino says,
{“confirmed”:true,“fPort”: 4,“data”:“030100”} even We tried with data in base64 format and the same, nothing happend, Anyone Know what could be happen?

It should work, i can try grab ours in the next week or two and play with it in the bench - it works fine via webui downlinks with bytes and base64 payloads.

try changing this example, this it’s for another device, but how it needs to be structured.

mosquitto_pub -d -h -p 1883 -u <USERNAME> -P <PASSWORD> -t 'application/<TENANT_ID>/device/<DEVICE_EUI>/command/down' -m '{"devEui": "<DEVICE_EUI (must match mqtt topic)>", "confirmed": true, "fPort": 129, "data": "AgAHAAgBAwADAAF0Cg=="}'
1 Like

Thank you ccall48, We have tried the way you told us but it didn’t work either.

But Finally We have managed to get it working, we think that the problem was in the tenant, because the gateway and the device Dragino with relay were in the Chirpstack tenant like you can see in the next pic

so we moved the gateway and the device to a new empty tenant

and we start sending (PUBLISH) commands via mqtt and finally start working with the way:

  • topic:

  • message:
    {“devEui”: “a840415a21875e4e”, “confirmed”: true, “fPort”: 5, “data”: “AwEA”}

with data of the payload 0x030100 converted in Base64