DR0 / Payload Size Question

I am in US915 region.

I have a few devices that send payloads > 11 bytes, which does not work on US915 w/DR0.

Is there a way on the application/network server side to prohibit a device using DR0, so that I get the larger payloads?

The devices are connected OTAA and ADR is on.

Thank you in advance! And my apologies if this is something I should have been able to figure out myself in the documentation (I did look 1st though!).


There is no way to prohibit a device from using DR0, but if there is enough margin, the NS will try to optimize the DR using ADR.


I can't figure out how ADR works. I have devices in the same location as the gateway (3-5 meters line of sight, no obstructions), and some that are hundreds of meters away.

In both cases they are all DR0. In fact… I’ve never seen the DR be anything but DR0 on every device I have paired (except 1). No idea why they are (almost) all DR0.

See next post…

:sob: :sob: :sob: :sob:

I’m such an idiot… I found the issue on my DR all being DR0! In the service profile I had the “Maximum allowed data-rate” still at the default setting of zero.

I assumed that on zero it would use the max data rate based on the region settings… Obviously not, as since I changed it to 4 I’ve already seen two devices change DR from 0 to 3.

I wonder what other settings I have set incorrectly… :frowning:

EDIT: How about “Max EIRP” in a device profile? Does that need to be set, or is the default of zero OK there?

1 Like

That doesn’t affect anything :slight_smile: Actually, I think I’m going to remove it as other than informational, it doesn’t affect how ChirpStack is functioning. And most users wouldn’t even know the correct value as it is not always provided by the device vendor.