DRAGINO door sensor LDS01

Hi,

I have DRAGINO door sensor LDS01 and configured all in Chirpstack server. I can see JoinRequest and also JoinAccept in Chirpstack and that is all. It repeats constantly (JoinRequest /JoinAccept ), what could be wrong? Any hint is appreciated.
Screens:

Hi @Patar,

The sensor is probably not being able to receive the JoinAccept from the Network Server, so it makes its work and as it doesn’t receive it, it retries again and again for a max of 200 times.

Your rssi is -115 in uplink, and will be less in downlink, perhaps too low to receive it.

If possible, try to connect the device nearer to the gateway, and you confirm that it joins properly

Hi @pulidoj,

thank you for hints. Regarding distance of door sensor, while I’m testing it I have this door sensor 1 meter from GW. Strange.

Hi @pulidoj,

just update, it seems that I have found the problem. It seems that some GWs have problem with this door sensor.
I have another GW where one door sensor worked as expected. It sent messages in ABP mode and I can see them in Chirpstact app server and I have correctly decoded also the payload.
Cheers.

Patar

Hi all,

just update for those who want to use DRAGINO door sensor LDS01 in their projects.
One device of door sensor works quite good (in ABP mode, OTAA with ChirpStack didn’t work). Second one doesn’t work. I have made same settings for both devices and unfortunately second one some times connects and that’s it. So, Dragino success factor is 50% for now.

Summary - there were two problems I have:

  1. GW (Mikrotik) that I use more then year don’t accept Dragino device for some reason.
  2. Only one device from two works (bad luck?)

I’m running ChirpStack in Docker “latest” in private cloud.

Cheers
Patar

Good to know. I have 2x of the dragino door sensor en route to me right now. I’ll have to see if they like my RAK2245 gateway or not.

Hi,

I have some Mikrotik gateways and dragino devices working without problem using chirpstack.

Your device is one meter away from the gateway and you have a rssi of -115 ? Have you connected an antenna on the Mikrotik gateway ? The internal antenna in not connected by default and you need to open the gateway to connect it if you are not using an external antenna. Got me the first time…

https://help.mikrotik.com/docs/display/UM/wAP+LR8+kit
under “Antenna usage”

@Botched1 one device is running with RAK2245 w/o any problem. Let me know if you succeed. Here are my settings, to short your time a little bit with exploration:
Password : 123456
Set log level (0 - no logs on the screen, too noisy): AT+ILOGLVL=0
Join mode (Default 0: OTAA, 1: ABP): AT+CJOINMODE=1
Disable ADR (0 – ADR Disable, 1 – ADR Enable, default CADR=1): AT+CADR=0
Set data rate (default is CDATARATE=5): AT+CDATARATE=0

Hi @hha, I have original Mikrotik external antenna (that big one), for testing I had it unplugged due to Dragino device was 1m from GW.
It is positive information that it works for you, I’ll give a door sensor with Mikrotik GW another try.
Just note, I have devices (environmental sensors) that work with Mikrotik inside house w/o antenna even over the wall :slight_smile: … and rssi:-115

Thanks. I plan on trying it OTAA + ADR first, as everything else on my gateway is OTAA + ADR and working fine.

Might be a week or two before I get to it though.

Agree, OTAA is best way to go, but I wasn’t successful with this device.

1 Like

@hha do you use also door sensors? If yes, do you running them in OTAA mode?

I have one door sensor since few days. It was joining fine with OTAA out of the box but mess with the ADR at first try. It was stuck in SF9 after join. It did receive new frequencies from the chirpstack server, acknowledge them, and then when the server tried to set the device to DR6 (SF7 250kHz) it acknowledge again and just did not change the spread factor. It looks like a bug in the firmware of the device. I changed the service profile on chirpstack to stick between DR0 to DR5 (not DR6) and now it works like a charm and change spread factor on order.

I did not had time to dig further, I will try to put some capture of the join and the firsts ADR frames soon.

Here is the config that I programmed on the device using the serial interface (in this order, not all are needed).

123456

// enable log
AT+ILOGLVL=5

// Set AppEUI
AT+CAPPEUI=0000000000000000
// Set AppKey
AT+CAPPKEY=00000000000000000000000000000000

// enable OTAA (default)
AT+CJOINMODE=0

// frequencies mask (default)
AT+CFREQBANDMASK=0001

// ?? do not remember what it is
AT+CULDLMODE=1

// class A only (default)
AT+CCLASS=0

// unconfirmed uplinks (default)
AT+CCONFIRM=0

// disable ADR to change datarate
AT+CADR=0

// set default datarate to SF9 (default)
AT+CDATARATE=3

// uplink port (default)
AT+CAPPPORT=10

// send uplink every 24h
AT+TDC=86400

// downlink frequency (default)
AT+CRXP=0,0,86952500

// RX1 delay 1s (default)
AT+CRX1DELAY=1

// send message on door open-close (default)
AT+DISALARM=0

// enable ADR (default)
AT+CADR=1

// start auto join (60s delay, 255 retry) (256 like datasheet will overflow)
AT+CJOIN=1,1,60,255

// disable log
AT+ILOGLVL=0

// save config to EEPROM
AT+CSAVE

// go to deep sleep
AT+CLPM=1

Here is the chirpstack config:

Service profile:

  • minimum DR0
  • maximum DR5

Device profile:

  • version 1.0.3

  • rev B

  • default ADR

  • max EIRP 0

  • uplink interval 86400

  • join OTAA enabled

I just copy the device EUI from the device to chirpstack and generated a new application key from chirpstack that I copied on the device. But you can enter what is on the box of the device in chirpstack and this will works fine.

Hope this helps.

1 Like

Great!! Thanks for config info, I’ll give it a try over the weekend and I’ll come back with results.

Just to follow-up on this, I joined 4x Dragino LWL01 water sensors and 2x Dragino LDS01 door sensors today.

All working OTAA (US915) with no issues. Using the default configuration (No AT commands used).

@Botched1 you are lucky man! :slight_smile:, what did you set on ChirpStack side? What GW are you using?

@hha I followed your instructions and set parameters on the device which seems wasn’t working and it started to work in OTAA mode. Great! @hha you saved my life and device, thank you. So Dragino success factor is 100%. I have communicated with Dragino support for several weeks and didn’t solved nothing. It seems that they brought only confusion to my setting/problems. Maybe if I did “plug and forget” strategy as @Botched1 it would be better :slight_smile:
So, problem is solved for now.
Have a nice rest of the weekend.

Hi all,

just update/follow up with one month or so with Dragino door sensors.
Configuration: RAK GW (PI HAT), Dragino door sensors, one is running in ABP mode and second one in OTAA mode, ChirpStack v3.12 in Docker in the cloud.
On diagram you can see behavior of the sensors over some time. Both sensor have heavy load of activity:

Best regards, Patar.