Dragino LG01-P & Application Server Issues

Hello everyone,

I am trying to troubleshoot a problem that I have with the Chirpstack Application Server and would appreciate some assistance.

I own a Dragino LG01-P gateway and six Dragino LoRa shields placed on Arduino Mega boards. My simple application requires the gathering of the sensor readings to a server.

I started by configuring the gateway and the shields to join the TTN network and everything worked fine, down to the payload decoder.

Then, I proceeded on making my own Chirpstack server. I followed the instructions to the letter, set up Chirpstack just fine, and adjusted the gateway to forward the packets to its local address.

The problem is that, although I am getting unconfirmed data uplinks in the network server (live LW frames), I am getting nothing in the application server. I tried various device settings to no avail. I am at a loss here and cannot figure out why I am getting nothing in the application server, even though the gateway is visible and I am getting packets to it just fine.

Any help troubleshooting this issue is welcome.