Enabled_uplink_channels for all channels US Configuration

When we use the default configuration provided (enabled_uplink_channels=[0, 1, 2, 3, 4, 5, 6, 7]), the solution works well.
But when we remove the enabled_uplink_channels field from the chirpstack-network-server.toml to enable all channels for US region, we face connection issue with devices.

I don’t understand why we face such issue.

Does your gateway support listening on 72 channels (64 + 8)?

No a gateway only listen to 8 channels.
But we plan to connect multiple gateways, each one on different channels:
Gateway 1: channels 0 to 7
Gateway 2: channels 8 to 15

That is possible, but when you enable all channels before these gateways are connected, then it is expected that you will experience packet-loss as the NS will signal the device that it must use all channels.

So the NS send to the device the list of all channels the NS support?
But if Gateways are not located at the same place (they could be at the opposite side of the world), we will definitively end up in packet-loss situation.
What’s the best practice for this?

Yes, as part of the join-accept (LoRaWAN 1.0.3) or after the join-accept through mac-commands (< LoRaWAN 1.0.2), the NS will tell the device which channels are enabled.

You could “bundle” multiple 8-channel gateways to support more than 8 channels, but if that is not the case, I would configure all gateways to the same (8) channels, matching the enabled_uplink_channels.

Thank you very much for the clarification.
Does it mean that the cleanest way to handle such scenario would be to have a NS per channel-set?

What would be the reason to no configure all gateways to the same channels?