Error="get channel error: no channel found for frequency: -1, dr: 3"

Hello guys,

I used the NS with the initial configuration in EU868 and it worked perfectly.
Now, I have changed it to the AU915 configuration and I have run into the error below. I have already checked the entire configuration file.

Feb 28 13:54:27 jmrasp3bpi chirpstack-network-server[3223]: time=“2021-02-28T13:54:27-03:00” level=info msg=“gateway/mqtt: uplink frame received” gateway_id=a 840411ce008ffff uplink_id=16b97388-4139-43b1-9ce6-b84a945b0f0a
Feb 28 13:54:27 jmrasp3bpi chirpstack-network-server[3223]: time=“2021-02-28T13:54:27-03:00” level=info msg=“uplink: frame(s) collected” ctx_id=893629f8-9945- 4c84-af15-1107f535d514 mtype=UnconfirmedDataUp uplink_ids="[16b97388-4139-43b1-9ce6-b84a945b0f0a]"
Feb 28 13:54:27 jmrasp3bpi chirpstack-network-server[3223]: time=“2021-02-28T13:54:27-03:00” level=error msg=“uplink: processing uplink frame error” ctx_id=89 3629f8-9945-4c84-af15-1107f535d514 error=“get channel error: no channel found for frequency: -1, dr: 3”

Would anyone know how to indicate a way to correct this error?

Thank you in advance

Sincerely,

Please validate what is causing the -1 frequency. ChirpStack tries to map the uplink frequency to a channel index, -1 is not a valid frequency and an error is raised.

Hi brocaar,

I am using the AU915 frequency plan.
The node is made up of Arduino Uno + Dragino LoRaShield. The GW is a Dragino LG01-P, Single Channel, working on the frequency 916800000, DR5. The settings work perfectly in the TTN.

Below are my settings on chirpstack-network-server.toml.

[general]
log_level=4
log_to_syslog=false
[postgresql]
dsn="postgres://chirpstack_ns:CSLoRaWAN@localhost/chirpstack_ns?sslmode=disable"
[redis]
url="redis://localhost:6379"
[network_server]
net_id="181179"
  [network_server.band]
  name="AU915"
  [network_server.network_settings]
  rx_window=0
  rx2_frequency=923300000
  downlink_tx_power=-1
  disable_mac_commands=false
  disable_adr=true
  enabled_uplink_channels=[8]
  [network_server.api]
  bind="0.0.0.0:8000"
  [network_server.gateway.backend]
  type="mqtt"
    [network_server.gateway.backend.mqtt]
    event_topic="gateway/+/event/+"
    command_topic_template="gateway/{{ .GatewayID }}/command/{{ .CommandType }}"
    server="tcp://localhost:1883"
    username=""
    password=""
[metrics]
timezone="Local"
[join_server]
  [join_server.default]
  server="http://localhost:8003"

What can I be doing wrong in the settings?

Best Regards,

But is this frequency also exposed in the data it sends to the ChirpStack Gateway Bridge? It seems -1 is reported which is invalid.