Error: no last RX-Info set available


While publishing the data from the end node to LoRa Server, we are getting the following error:

level=error msg=“schedule next device-queue item error” dev_eui=0807060504030201 error=“no last RX-Info set available”

Would be great if some genial soul can assist us in resolving this issue. Let me know if you need any other information/code snippet/configuration details.

Thanks in advance!

It looks like your device is configured as a class-c device. In order for the network-server to be able to send data to the device, the device must first send an uplink frame so that the network-server knows which gateway is within reach of your device.


So it got solved. I had unchecked the Class C device configuration before asking the question and this issue was owing to some configuration issue. In the application created we had made the data pass through the gateway and after removing it, worked fine.

One more thing… I am having a couple of issues with the MQTT Broker understanding. As is explained, LoRa uses the MQTT protocol for message relaying. Where exactly is the broker hosted? On the Network Server or the Gateway? Or is it some kind of a middleware that acts as a separate entity other than the gateway and n/w server?

Got the answer for the above query as well.

Thank you for your assistance @brocaar. Kindly consider this topic as closed.