Error showing config v3.11.1


I’ve just tried installing chirpstack-application-server on a Ubuntu 18.04 machine, and I get the following error when I run chirpstack-application-server configfile immediately after installing it.

FATA[0000] execute config template error: template: config:353:27: executing "config" at <.ApplicationServer.Integration.TLS>: can't evaluate field TLS in type struct { Marshaler string "mapstructure:\"marshaler\""; Backend string "mapstructure:\"backend\""; Enabled []string "mapstructure:\"enabled\""; AWSSNS config.IntegrationAWSSNSConfig "mapstructure:\"aws_sns\""; AzureServiceBus config.IntegrationAzureConfig "mapstructure:\"azure_service_bus\""; MQTT config.IntegrationMQTTConfig "mapstructure:\"mqtt\""; GCPPubSub config.IntegrationGCPConfig "mapstructure:\"gcp_pub_sub\""; Kafka config.IntegrationKafkaConfig "mapstructure:\"kafka\""; PostgreSQL config.IntegrationPostgreSQLConfig "mapstructure:\"postgresql\""; AMQP config.IntegrationAMQPConfig "mapstructure:\"amqp\"" }

I also had this happen to our existing installation which I was trying to upgrade to the latest version.



This issue is already merged to latest branch

1 Like

@sagarpatel thanks very much for this!

I will create a new release in the next days :slight_smile:

1 Like

Hi @brocaar!

We encountered the same problem as @james1 posted above, also running on a Ubuntu 18.04 VM. In the process of upgrading loraserver to chirpstack, we installed chirpstack-application-server v3.11 and seem to be dead in the water now. If possible, I’d like to install v3.10, but can’t find that version in the repository.

Would it possible to move version 3.11 chirpstack-application-server packages to the “testing” repository and have v3.10 put in the “stable” repository for a while? I couldn’t pull any chirpstack-application-server packages from the testing repository so I’m assuming that v3.11 is the only version 3 available right now.

thank you!