error=Unknown data-rate on EU868 with Coding Rate 4/7


I just tried to switch from v3 to v4. But I always get the following error for some of my sensors:

ERROR chirpstack::uplink: Deduplication error error=Unknown data-rate: Lora(LoraDataRate { spreading_factor: 7, bandwidth: 125000, coding_rate: “4/7” })

I am using the EU868.
The json uplink from the gateway (unfortunately I had to extract it per hand from the gateway as the live “LoRaWAN frames” tab doesn’t show anything, although Chirpstack tags it as online)


Thanks in advance,

So the problem was the coding_rate. As ChatGPT told me the coding rate of 4/7 is not beeing used in EU868 normally. Flashed the device to use 4/5 fixed it. But I would really love to hear if there is a chance to get also data from devices who are sending cr of 4/7 like it was possible in Chirpstack 3.


There will not be such option. Please note that (as far as I know), a different coding-rate also implies a different airtime (because of the added / removed redundancy). This would mean different max-payload sizes than specified. Please see also:


Hello! Have you solved the problem with displaying data in “LoRaWAN frames” tab? I have this problem too. But i see statistics from station also )

i have changed back marshaller to “protobuf” in chirpstack-gateway-bridge.toml and LoRaWAN frames appears ))

And also my logs become clear at all (except network errors)

Hey @NikitaK ,
I found out that it has to do with gRPC Streams and my AntiVirus (Sophos) see here: Events or the LoRaWAN frames tabs empty due to antivirus · Issue #44 · chirpstack/chirpstack (

I couldnt solve it though…
@brocaar all right, I think our intern made a wrong decission there, we will have to flash all devices manually to the right coding rate… thanks anyways :slight_smile:

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.