Expired GPG key for NS Debian packages

Looks like your GPG signature key has expired on 1st of Jan 2022?
The following signatures were invalid: EXPKEYSIG CFF064C9D12ECB34 Orne Brocaar info@brocaar.com

root@CIE-4075:~# gpg --list-keys --no-default-keyring --keyring /usr/share/keyrings/chirpstack-archive-keyring.gpg -v
gpg: using pgp trust model
gpg: Note: signature key CFF064C9D12ECB34 expired Sat 01 Jan 2022 17:07:43 GMT

pub rsa4096 2017-01-13 [SC]
uid [ unknown] Orne Brocaar info@brocaar.com
sub rsa4096 2017-01-13 [S] [expired: 2022-01-01]
sub rsa4096 2017-01-13 [E]


I had the same problem, found the solution here:

sudo apt-key adv --keyserver keyserver.ubuntu.com --recv-keys 1CE2AFD36DBCCA00

Hello everyone;
This is my first post.
I have an old chirpstack version working in one server and I am trying to install the last version on a new Debian 11 server.
The command above does not work for me.

The server is behind a proxy and that option is working. Without that option I receive a “Connection timed out”

nmartinez@lns:~$ sudo apt-key adv --keyserver-options http-proxy=http://myproxyip:port/ --keyserver keyserver.ubuntu.com --recv-keys 1CE2AFD36DBCCA00
Warning: apt-key is deprecated. Manage keyring files in trusted.gpg.d instead (see apt-key(8)).
Executing: /tmp/apt-key-gpghome.2xZ5jIbZO2/gpg.1.sh --keyserver-options http-proxy=http://myproxyip:port/ --keyserver keyserver.ubuntu.com --recv-keys 1CE2AFD36DBCCA00
gpg: CRC error; 9E95B3 - 88852E
gpg: read_block: read error: Invalid keyring
gpg: Total number processed: 0

I have tried too with hkp://keyserver.ubuntu.com:80, keyserver.ubuntu,com:80, hkp://keyserver.ubuntu.com, every time with the same result.

Any idea to share?
Thank you very much.


Well, finally I could generate the gpg file manually and then apt update worked ok!