Fetch from repos.loraserver.io - operation timed out

Hello Everyone,

I am new at LoRa, and trying to setup a new LoRa Server on a new Ubuntu 16.04 LTS PC.

The instructions I followed are https://www.loraserver.io/install/quick-install/, but I stuck at the step “Setup LoRa Server software repository”.

Allow me append the error messages:

It looks like the file “InRelease” cannot be fetched. Therefore I tried another tool wget but it also was stuck.

As a referrence, I also tried another repositry, skype. It works fine.

Please let me know why I cannot fetch the file.


Let me append the wget message:

Skype’s file can be fetched but loraserver’s cannot.

Please help!

Have you tried to access https://repos.loraserver.io from a different machine, or from your browser? Getting an operation timed out is usually not related to missing files and is usually related to firewalls etc…

1 Like

Hello Brocaar,

Thanks for your quick reply. I just tried the browser (at the same machine). It is amazing that both Release files (in loraserver and skype) can be fetched by my chrome. This PC is new installed as an ubuntu machine, I have not touched any firewall stuff.

On the other hand, I realized another strange phenomenon. When I fetched it from loraserver.io, this file would be saved as a file. However, the file from skype.com would directly be shown in the browser (it is a text file.)

could this phenomenon be a clue?

Thanks for your answer Sincerely.

Hello @brocaar,

I just verified another machine, it can wget files from loraserver.io. I think you are right – it is a firewall issue. I will check the default firewall setting and will share what I get here. Thanks!


Hello Guys,

I just realized that the firewall is setting by my ISP (Internet service provider). It blocks data from loraserver.io. I will complain this with them. Thanks for your time and attentsion.