Force NewChannelReq


We keep trying new LoRa concepts and now we are trying to activate Channel 8 (867.3 SF7BW250) It seems to work if I replace one of the 5 CF channels but I want it to work as an extra channel (NewChannelReq)

Can this command be forced? It seems to work if I got rid of the extra channels and only left it behind.


Yes, you can configure this using the loraserver.toml configuration:

  # [[network_server.network_settings.extra_channels]]
  # frequency=867300000
  # min_dr=0
  # max_dr=5

All channels that do not fit within the CFList (join-accept) will be sent as NewChannelReq mac-command :slight_smile:

Is automatic the request?

I’ve trying and don’t seem capable to do it. Probably messed with my configuration activating and deactivating channels.

Configured like this

Will keep trying.


Seems to work. Messed my configuration and had to reset everything

Seems that server is deactivating the channel with CHMask


I don’t know where I have the error. I have been checking the src and it seems that the enable channels are loaded in config
3 + len(extra_channels)
But the server is not adding the channel number 8 to ChMask.

So it seems that server handles me the new channel with the request and then with the ADR and the CHMask gets rid of it telling the device to use only the 8 first channels

Okay. Here is what I’ve got after all the test I’ve done

  • Sometime channel 8 does not appear.
  • If I reset the server starts working during a time.
  • After some joins channel 8 gets deactivated by ChMask.
  • When CH 8 is working the ADR engine never gives the posibilty to send in DR6 does not matter how everything is configured DR5 is always selected

Have more news.

I don’t know why but I changed the config of Channel 8 to 868.3 SF7BW250 and it seems to work now.
@brocaar Could it be possible that loraserver found the same freq 2 times (867.3) and discards the last one? That’s the only thing that make sense to me

Server still does not select DR6 always DR5

Now it seems to dissapear whenever I change something in gateway-profiles.

Better explanation:

  • Add extra-channels to gateway-profile
  • Submit
  • Server disables channel 8
  • Remove all extra-channels from gateway-profile
  • Restart loraserver
  • Server renables channel 8

DR6 nevers get selected

The gateway-profile only changes the gateway configuration. It does not affect the configuration of devices. It is expected behavior that the ADR algorithm does not change the device to DR6. With DR0 - DR5 the uplinks (and downlinks) are spread over multiple channels. When the ADR algorithm would ask your devices to change to DR6, it would put all these devices on a single channels, potentially causing a lot of collisions.

Ok. Thank you.

We have read the manual of Semtech and it says that the “std_channel” is intended for gateway intercomunication so we won’t use it.

Thank you for clarification

Note that you still could enable it by the application-layer of your device. E.g. turn off ADR and then change the device to DR6 manually (device application).

Yes. Thats what we first tried and it worked like a charm.

We thought to use it because the lora packet are less time on air because they can transmit faster. Maybe we will find some utility in the future.

Thanks again

This was a bug and has been fixed thanks to your comment :+1:

1 Like