Gate way OS - Starting lora-app-server

Hi all,

I am new to LORA . I have installed gate way os full image on respberry pi 3. All installations were successful and i was able to bring up the cli and config the gate way. But I have trouble in accessing the lora-app-server web interface. Since there is no browser, i am not able to access the web interface. Looks like HTTP is not recognized as a command. Can you please advice.

In the document it reads after installation access lora-app-server web interface by typing http://localhost:8080. But this is not working,

From where device are you trying to access? Instead of using localhost, locate the ip address of pi within the network you are using and use that.

Thanks… It worked. thanks for your help. I was able to install full gateway os and bring up the web interface and configure network server, application ,devices and profiles. Node is transmitting… But nothing is received by the lora server. Not sure how to check if gateway is picking up the msg and forwarding to the server. Node says it successfully transmitted the message. Is there a way to check in the gateway logs or in the server logs ?

Would appreciate any help. Thanks. I am using SX 1276 lora chip… for both node and gateway.

I see this error in the logs. Packer forwarder is not getting started. Not sure why…

‘lora-packet-forwarder’ failed to start (exit status 0) – ‘/etc/init.d/lora-packet-forwarder start’: Starting lora-packet-forwarder

start the packet forwarder binary manually and see the stdout log output.

I tried that already. Still the same issue. Will the gateway full os support only certain chip set ? i am using SX1276. Should I do any configuration for this chipset like pin, freq configuration etc?

Oh… SX1276 is not a GW chipset so packet forwarder will not work. There are some projects trying to make a single-channel LoRa gateway from it, but that can never be a LoRaWAN gateway which is ussualy built around SX130x.

What it’s your gateway full os support version? Since newer version uses concentratord software, a new member of Chirpstack :wink: that will make a bit easier the setup of you gateway and in addition introduce a new approach to be as close as possible of the HAL libraries that control the gateway chips.

I am assuming that you are using an older version of full os that supports packet forwarder. Usually the way to debug what’s happening on packet forwarder side is to check the logs and see if there is some clue about the issue that you are having. I think that as you mentioned the use of a SX1276 chip on your gateway, it’s impossible for packet forwarder to init (for example, reset the SX1301 / SX1302), as I said, packet forwarder under the hood, uses the HAL libraries to communicate with this specific chip models, this is the way packet forwarder won’t work using SX1276 chip, that most of the time, that kind of chip is used on the end node instead.

Thanks for all the replies. Looks like I am using the older version of the s/w and without proper chipset. I have ordered the RAK2245 RPi HAT Edition - LoRaWAN® Gateway Concentrator Module. Will test with the concentrator when i receive it and let know how it goes.

I have also ordered wave share SIM7600E-H 4 G hat. Hope these 2 can work well together with raspberry pie 3 to construct a 4 G enabled GPS Lorawan gateway,


I am using waveshare sim7600 4g hat. I was able to install the device driver in windws 10 pc and connect the modem… Able to check the at command and it is working. When I check registration using at+creg it returns ok.

But when I try to call or connect to internet it always give me a error msg " No carrier " My internet connection displays the correct carrier name and shows good signal strength but says “turned off”. Any advice on how to turn on the connection for this hat ?