Gateway Bridge with a MQTT Broker

Hello All,

I have installed a gateway bridge on RAK2245 and the Network Server and Application Server on Linux (running on orcale virtualbox on windows host).

To get the data from the gateway to the seperate IP i need to bridge it using MQTT as far as i have understood.

The IP of my virtual box is and it runs perfectly fine on different desktops in my office as can be seen.

The Gateway contains the gateway bridge and i bridged the MQTT authentication to my virutal box IP, but the gateway shows never connected

I did all the steps but the data is still not being sent.
I tried to update the Gateway Bridge configuration so that it connects to a different MQTT broker.

Gateway Bridge Configuration file:

MQTT authentication.


Type defines the MQTT authentication type to use.

Set this to the name of one of the sections below.


# Generic MQTT authentication.
# MQTT server (e.g. scheme://host:port where scheme is tcp, ssl or ws)

# Connect with the given username (optional)

# Connect with the given password (optional)

Please help me to complete this.

Thanking you in anticipation.

1 Like

I had the same problem a few weeks ago. In my case the problem was that, I had configured the MQTT on the server with an username and password, and in the gateway I had not setted it. Check in the configuration file on the server (your virtual machine) if you have usernames and passwords configured.

If not, be sure you allow “anonymous” loggins in the MQTT configuration file.

Also check if the gateway “sees” the server in the network, pinging, for example.

Ok great, thanks for the heads up. I’ll Look in to it.