Gateway MileSight UG63 unseen

Hi everybody,
I’m unable to connect my gateway MileSight UG63 to chirpstack. I’m using the docker compose file installation with chirpstack V4.
On the mosquitto logs I can see the subscription of the network server and the message published by the gateway.

I have configurated the milesigth gateway to use a topic prefix eu868.
The MQTT backend for the region eu868 is configured to have topic_prefix=“eu868” .

I don’t under why the gateway is still unseen.
The network server look like to subscribe topic like “eu868/gateway/+/event/+” and not simply “eu868”. When the gateway send a message, I don’t any message sent to the network server.

Am I missing something?

Best regards

Do you have a device on the network? Until the gateway sends an uplink from a device it will remain “unseen” in the web interface.

Definitely not super intuitive, IMO it would make more sense for the Gateway to get a “seen” timestamp when it sends stats, but thats how Chirpstack works.

As for your confusion on the MQTT topics, the “eu868” you configure on the gateway is only the topic prefix not the entire topic itself.

Heres a list of Chirpstack’s MQTT events and their topics:

  • Up - Uplink from Device
    Topic: “<region_prefix>/gateway/<gateway_id>/event/up”

  • Down - Downlink Queued to Send to Device
    Topic: “<region_prefix>/gateway/<gateway_id>/command/down”

  • Status - Routine Gateway Status Update
    Topic: “<region_prefix>/gateway/<gateway_id>/event/stats”

  • Ack - Confirmed Downlink Acknowledgment
    Topic: “<region_prefix>/gateway/<gateway_id>/event/ack”

  • Integration - Any events sent to MQTT integration
    Topic: “application/<application_id>/device/<dev_EUI>/event/<event.>”

Note that the “integration” event is actually several events that are configurable through Chirpstacks MQTT Integration.

So when Chirpstack subscribes to “eu868/gateway/+/event/+” it is subscribing to all the events from all your gateways that use the eu868 topic prefix, as expected.

Thank you Philipp for the help.
Yes I have 2 sensors connected to the gateway.
On the gateway side I have tested two different strings for topic:
‘eu868’ only and ‘eu868/gateway/UG63/event/uplink’
Both doesn’t work. For the second topics I got error in log.
ERROR chirpstack::gateway::backend::mqtt: Processing gateway event error: Unknown event type region_id=eu868 topic=“eu868/gateway/UG63/event/uplink " qos=0”

In this support note (applicable to my gateway), the vendor say that chirpstack server V4 is not supported with MQTT.

Using an UDP Semtech packet forwarder I’m able to connect the devices.

Ya that’s unfortunate, but looks like your stuck to UDP if you want to use that gateway. I assume this is because the Gateways come with old GW Bridges installed, if you really wanted to get your hands dirty you might be able to install a newer one that is compatible with V4.

For reference the three topic lines for eu868 should be as follows:

event_topic_template="eu868/gateway/{{ .GatewayID }}/event/{{ .EventType }}"
command_topic_template="eu868/gateway/{{ .GatewayID }}/command/#"
state_topic_template="eu868/gateway/{{ .GatewayID }}/state/{{ .StateType }}"

Official documentation of chirpstack said that the GW bridge is compatible with both chirpstack V3 and V4, if the protobuf marshaller is activated.
I cannot confirm if it is the issue because I haven’t found any information about the version of chirpstack MQTT forwarder installed. They may keep it secret

I suggest to mark the topic as solved


I believe that documentation is saying that protobuf marshaller needs to be used if you are using the most recent gw bridge to connect to Chirpstack V3. The gateway bridge should be compatible with V4 regardless.

Besides an admin you are the only one who can mark a topic as solved by clicking the ‘solution’ button beside a message.