Gateway OS forwarding to TTN

Hi,

I’m running the newest Gateway OS running on an IMST Lite Gateway.
I’d like to forward packages to TTN.

I should be able to do that with the chirpstack-packet-multiplexer, which should be part of chirpstack.
see: https://github.com/brocaar/chirpstack-packet-multiplexer

Just that I can’t find the multiplexer on the Pi Gateway OS.

What am I missing?
Thanks
heleb

There is a not-yet documented feature in the latest GW OS, called ChirpStack UDP Bridge. It implements the Semtech UDP protocol and it could be used to forward data to TTN. You can run it next to the ChirpStack Gateway Bridge:

  • Configuration: /etc/chirpstack-udp-bridge/chirpstack-udp-bridge.toml
  • To start /etc/init.d/chirpstack-udp-bridge start

(it does not start automatically on boot)

Thanks brocaar,

tried it out, but packages did not show up in TTN (V2) .
The IMST Lora Lite gateway did receive packages, they were shown in gateway package view.
I tried various names for TTN server, none worked.

Tried with and without gateway-bridge, restarted network-server, but no luck.

chirpstack-udp-bridge.toml:
(the red lines have no meaning)

Did you confirm that the ChirpStack UDP Bridge was running? You can see this in the /var/log/messages file.

I just revisited this.
Updated Pi3 today with newest full swu.

Updated /etc/chirpstack-udp-bridge/chirpstack-udp-bridge.toml to point to correct server server="router.eu.thethings.network:1700"

Had to sudo the command: /etc/init.d/chirpstack-udp-bridge start

Success! The Chirpstack Gateway now shows up active in TTN V2

Thanks !!!

1 Like