Gateway OS time is over a month out and can not update it

I have the lora Gateway OS base installed on LorixOne gateway.

I have two different times though.

On lora-server I have a time and date of: Fri Mar 29 00:56:33 UTC 2019

On the gateway using the image downloaded from for this gateway I have the time and date of Mon Feb 25 18:23:40 UTC 2019

As you can see not only is the time off the date is also by one month and 4 days.

I have tried to update the NTP. In the file etc.ntp.conf it says ‘File ‘ntp.conf’ is unwritable’

I also have tried to update through sudo opkg but again I get errors.

How can I update the time in the gateway?

On the lora-app-server it is telling me it last saw the gateway 5 hours ago. The gateway does have connection (I am not yet at the stage of adding devices (MOATs). All my tests do far do show the gateway is talking to the loraserver. But the time is way off. The time should be telling me it saw it a few seconds ago.

Any help greatly appreciated.

I’m in the same situation

Pretty late response but it keeps working for GatewayOS (I’m currently using v4.0.0 test2)

type, for example, sudo date -s ‘2022-06-16 13:30:10’

More details here