Getting started with MKRWAN1300

Hi everyone, I’m new on the forum and in the LoRa world.

I approached this world because I need to create a private LoRa network.

My goal is to manage 180 hydraulic valves placed in the area of 5 km in the middle of nature, it is apple orchards.

I downloaded LoRa OS at the last link.
I created the SD and put it in the Raspberry and after booting I didn’t change anything on Raspberry but I connected directly to the Web Interface, did I do well?

I know that there is also the interface on the S.O. via the “sudo gateway-config” command but I didn’t do anything wrong?

I would like to create a communication with about 180 Nodes made with Arduino MKR WAN 1300 LoRa.

Has someone already done it?

Thank you all for your attention

First thing to do is probably to read up on the design errors in that board.

It may sort of work in the short term especially if you fix the error that supplies 5v to a 3v3 part(!), but you’ll likely want the 1310 instead.

Do you have power supplied to the nodes? What you want will be rather tricky on battery, unless you can accept a fairly high delay (at least several minutes) in getting commands to the nodes. You may need to build in failsafe turn-water-off timers in the node firmware.

Several minutes delay on turning off irrigation valve should not be an issue, however I augree with you that instead of giving commands “turn on valve” and “turn off valve” it may be better to give command like “turn on valve for 20 min” so that valve will always be turned off automatically in case of a communication failure.

Thank you all for the advice but I have a problem behind it all.

I installed LoRa OS Full on my SD card and inserted it into Raspi, after starting I connect to the network at where I see the graphic interface LoRa Server.

During the creation of the Network-Server it gives me the error “context deadline exceeded (code: 2)” as seen in the Screen.

In practice I configured my concentrator (ic880a) in “sudo gateway-config” and indicated the reset pin number 22.

Now it works and makes me create the network server!

Now I have another problem, I can’t connect the gateway to LoRa Server, “Last seen” always remains on “Invalid Date”.

Where am I wrong?

I noted that last seen is based on the time-stamp recived from gateway, as when my gateway (Kerlink femton) internal clock was not set correctly it said last seen two month ago even though it recived message from only a minute ago. So I would suggest start looking at rtc of the gateway and the timestamp of incomming message.

Thanks a lot. Can you tell me exactly how to set the time?

That depend on your gateway. Kerlink has two options, manually or NTP, NTP is preferred as Kerlink femton lacks battery backup so if you set the clock manually it will lose the time setting in case of power loss.

What gateway do you use?

Ok I’m using the IC880A

From what I can see this is not in itself a complete gateway, it will depend on the time of its host-system, i.e. the Raspberry pi. Found in an article that Rasp pi do not have an RTC, which is likely the root-cause of your problem, no time and date-> invalid date. See article how to get time to Rasp Pi through NTP.

I’d be surprised if this has anything to do with the gateway’s system clock.

Rather, it looks like the gateway simply has never reported in any packets in this session.

Checking the syslog / journal log on the gateway would be useful

ie sudo journalctl -f or sudo tail -f /var/log/syslog

Also make sure there’s a node in range that is actually transmitting on a frequency the gateway monitors.

1 Like

I tried the guide but the “apt-get” commands do not exist on LoRa OS.

How can I do?

Same thing with the commands “sudo journalctl -f” tells me “sudo: journalctl: command not found”

Help me please

I try to explain my problem:

I installed LoRa OS FULL on raspberry Pi3 B +.

In “sudo gateway-config” I selected my concentrator.

I created the localhost network server: 8000.

I didn’t create any Gateway Profiles.

In Service-profiles I have attached the screen so you can see to understand immediately the best.

In Device-profiles I have attached the screen so you can see to understand immediately the best.

And finally I put the Gateway setting screen.

On the arduino MKR WAN 1300 I have loaded the sketch “LoraSendAndReceive” compiling the variables SECRET_APP_EUI and SECRET_APP_KEY with the data generated on the Server (I put the screen).

The serial monitor always gives me the message “Something went wrong; are you indoor? Move near a window and retry” and I don’t understand why.

Is there anyone who can help me?

Thank you in advance for your support

1 Like

Hello, Any solution to your problem?