Getting started with RAK2245 and Chirpstack GatewayOS

Complete Chirpstack newbie here, although I have a few MultiTech Conduit gateways on TTN and a bunch of nodes.

I installed the chirpstack-gateway-os-full image on a Raspberry Pi 3 with the RAK2245 Hat.

I went through the installation steps on

In gateway-config I ran “Setup LoRa concentrator shield” and selected the RAK2245 on the US915 plan with Channels 0-7 +64

I can see my gateway in the UI, with correct GPS coordinates and a “few seconds ago” last seen. So, I know the hardware is working. In fact, I had previously configured it as a TTN gateway using the RAK Pi image and that worked as well.

With the Chirpstack Gateway image, I don’t see any frames in the “LIVE LORAWAN FRAMES” view. I have configured a couple nodes configured, and there are other nearby LoRaWAN nodes that are happily communicating over a different gateway to TTN.

I don’t really know where to start to troubleshoot this. There isn’t anything apparent in the log file.

Very occasionally I will see a message like:
Apr 05 23:18:08 raspberrypi3 chirpstack-concentratord-sx1301[5817]: Frame received, uplink_id: 5d5fcc5a-f893-4561-b798-e274e7d13e2f, count_us: 361366499, freq: 903100000, bw: 125000, mod: LoRa, dr: SF7

Which I assume is a glimmer of hope from another nearby node.

Most of the log file messages are “Publishing stats event”, or “finished unary call”.

How can I troubleshoot this?

I solved this in the “Setup LoRa concentrator shield” configuration:
Select Shield: RAK2245
Select channel-plan: US915
Select the US915 channel-block: Channels 8 - 15 + 65

The last setting certainly wasn’t obvious to me. This got me on the right path, since it lists the defaults for various 8 channel gateways.

On the pi, the config script copies:

Hopefully this can save someone else the weekend of frustration I went through.