Global_conf.json question?

I have an RPi5 / WM1302…I installed the chirpstack gateway bridge and chirpstack. The global_conf.json is using port 1700 and the chirpstack gateway bridge toml
is looking at 1700 (see line below)

udp_bind = “”

My question is wrt global_conf.json line:

“server_address”: “”,

now that I am no longer using TTN what should I change this line to so that the packets get pushed to the gateway bridge?

Thank you

Probably localhost or to point to the Gateway Bridge service running on the gateway.

1 Like

That change doesn’t seem to work…I am trying to get the UDP packet forwarder to communicate with the chirpstack-gateway-bridge. Do I need any other puzzle pieces for this like mosquitto, docker, ???, or should running these two be able to talk ? Could it be I am using RealVNC on my laptop to get into the Pi?

Ah, I thought you were asking what address to point the packet forwarder to.

That is the upstream MQTT server, whichever one is next to ChirpStack. It will be what sits between the Gateway Bridge and ChirpStack.

No I think you were on the correct track…I apologize as I am not accustomed to linux so I don’t see the complete picture here…I have installed mosquitto, docker, docker-compose, redis and postgresql using the chirpstack / requirements page via cut / paste…I then changed the global_conf.json to feed data to the mqtt using my local URL (192…) and port 1700. I also changed the chirpstack-gateway-bridge.toml to match this. I then call the lora_pkt_fwd -c global_conf.json and it runs. I then call

 sudo systemctl start chirpstack-gateway-bridge
sudo journalctl -u chirpstack-gateway-bridge -f -n 50

which gives the following repeating message:

I run docker ps and it shows the following:

I am sort of shooting blind here as I don’t really know what to try other than the exact commands that chirpstack seems to show or I google and try things but I don’t quite know how to get the connection up and running so that the UDP feeds the bridge.

I would like to solve this and ultimately put the network server on the rpi5. I am using a WM1302 (SEEED gateway). I have verified on TTN that the hardware and the lora_pkt_fwd executable works .

I hope this helps to clarify and I apologize if it is confusing .

Follow up:
I changed back to localhost in both global_conf.json and chirpstack-gateway-bridge.toml and now I get the following:

Could this now be working? Is there someway to tell as I don’t have Chirpstack up and running yet?

I am a little confused as the instructions want me to install mosquitto and docker etc…but when I run docker I don’t see a port tied to mosquitto yet the attached picture makes me think the gateway-bridge is using it…is docker not needed and just confusing the picture here?