GPIO 7 reset pin busy - Raspberry Pi 3


I’m using GatewayOS with a Brazillian gateway (Radioenge) on a Raspberry Pi 3. This hardware has an issue that was first reported on GPIO 7 reset pin busy · Issue #71 · brocaar/chirpstack-gateway-os · GitHub - the GPIO7 pin (reset) is busy, which prevents ConcentratorD to run. Is there a way to solve it without recompiling the entire GatewayOS?

The hardware used to work with GW OS 3.3.2 but did not worked after GW OS 3.3.3.

Hey there, I found a solution for my problem.

I had to download this precompiled file (firmware/spi0-2cs.dtbo at master · raspberrypi/firmware · GitHub) and put it into my SD card on folder /boot/overlays .

Then I edited the file /boot/config.txt (only the last line). The last line must be like

dtoverlay=spi0-2cs,cs1_pin=<another free pin different from 7>

In my case I used pin 31 for Raspberry Pi 3 (GPIO6) which is unused and it worked.

1 Like

Hi Rodrigo, I created an account just so I could thank you A LOT for the solution you provided !!

I was stuck with this problem for quiet a long time… Something around 10 days :’)

You can’t imagine how relieved I am right now haha, my gateway is finally working, thanks again ! :slight_smile:

1 Like

Hi !
The GatewayOS with a Brazillian gateway (Radioenge) is working ok for me on a Raspberry PI 3+. I had opened the Issue #71 and now it’s working OK with these parameters that I’ve set for GatewayOS v3.5.1 :

File chirpstack-concentratord/sx1301/global.toml:

File /boot/config.txt
Uncomment this line:

The channels from chirpstack-concentratord/sx1301/channels.toml should be defined according with Brazilian restrictions. Just for example: TTN AU915 uses channels from 8 to 15 and 65.

I hope this could help anyone here.