GPS RX timestamps running at double speed, self correcting once/min

If I watch incoming packets into the gateway, the chirpstack application server shows the correct time, but the gateway rxInfo time is actually running at double speed. It corrects itself once per minute. I ran a test with a single device sending an uplink every 15 seconds. This is what I see:

(Hours edited to account for daylight saving hours)

Chirpstack timestamp, rxInfo[0].time
17:03:46 17:03:46
17:04:01 17:04:16
17:04:16 17:04:46
17:04:31 17:15:16
17:04:46 17:04:46

You can see in that last reading the rxInfo time has corrected itself by going backwards. It does this every minute.

I’m trying to understand where the rxInfo timestamp comes from. Should it be coming from the GPS PPS (Pulse per second) feed?

All the GPS stuff seems to be working fine over UART and the gateway lat/long are correct. If I watch the GPS feed on the serial device, the time is as it should be.

Any pointers to what might be going on here, or where I should start looking will be gratefully received!

Thanks :slight_smile:

I believe this timestamp comes from the semtech packet forwarder and is related to the fact I’ve not got the PPS feed connected from the GPS to the module with the SX1308. I don’t know why that would cause the counter to run at double speed.

Solved by connecting the PPS feed from the GPS module to the Gateway module