Help with device EGK-LW22PLG


I have a fully updated Chirpstack 4 instans with all the service installed on same server.
I have Mikrotik knot router as Lorawan gateway

No matter what i do i cant get this device to join.

I have tried all the activations from the device documentions manual_egk-lw22plg [e n g i n k o . s u p p o r t . c e n t e r]

What logs can i provide to give you more infomation about this problems?

In the device manual i have tried both plan OTAA where i write JoinEUI and AppKey to the device.
I have tried the OTAA ENGINKO but im not sure what they mean by AppKey on request;

You may find the DevEUI and AppKey on the label of the device.
Or via other forms. Check the manual.

Then add the device to ChirpStack.

HI Datnus

I have a their app on android phone and i can read those info.
I have created the Device via device template.

The device will not activate.
I get alot “JoinRequest” and “JoinAccept” on the LoraWan frames tab, on the Events tab i get only Join

That is correct.
On Frames you will see JoinRequest and Join Accept.
On Events, you will only see Join.

Do you have any “up” packets?


Nope there is no other packets

Are you using LoRaWAN 1.1.0?
Try to use v1.0.3 or v1.0.4. Then dont need JoinEUI.

The manual says it a 1.0.2 C Class device.

The Device is created by Device-profile templates witch i have downloading using chirpstack guide.

HI all

I found the problem was on my mikrotik gateway that works as lorawan GW, the settings was Private instead of public network.

Thanks all for the help

1 Like