Hi, I can't start my chirpstack (bind: address already in use)

I’ve installed my chirpstack time ago and it was moreless working properly, for perfomance reasons I had to reset my server and once it turned on my chirpstack didn’t work anymore.

So in summary I deleted everything including docker, the docker images and my chirpstack installation as well. Then I tried to reinstall everything but I’m getting the next message once I run the docker:

ERROR: for chirpstack-application-server Cannot start service chirpstack-application-server: driver failed programming external connectivity on endpoint chirpstack-docker_chirpstack-application-server_1 (xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx): Error starting userland proxy: listen tcp4 0.0.0.0:8080: bind: address already in use

In my settings before I started the docket I specified to my chirpstack-application-server to use 9090:9090 port, also I’ve reinstalled several times all and I still getting this same message.

By the way I’m doing all this in CentOS.

What might I haven’t notice?

UPDATE

I just could fix this problem, the solution was that I had to edit both .yml files for the docker compose, in this case I had to change the port in both files:

sudo vim ~/chirpstack-docker/docker-compose-env.yml
sudo vim ~/chirpstack-docker/docker-compose.yml

But now I can’t acccess to the platform via web browser


Regards

Hi.
Assuming the port numbers in your docker-compose.yml file and application server configuration file are the same, and you’re binding the container to the correct host IP, I would check any networking after this.
i.e.

  • Is there a firewall running on your CentOS machine (try disabling for troubleshooting)?
  • Can you ping the container/docker-host?