High Packet Loss after upgrading to loraserver 2.7.0


2 weeks ago we updated our loraserver to version 2.8.1, we updated because the upgrading to ADR fit us, the one where you set DR Max and loraserver lowers the DR of all devices.

After the update we kind of saw a high packet loss on nodes that where working perfect before.


We updated the server the 6 of May

So I started digging a little with this node and try to check what is wrong.
We configured the MAX DR to 3 but the device still seems to not be working, If I set maxdr to 0 it seems to work fine.

I get messages with SNR -17 -19 and the server still sets DR to 3

What I don’t really understand is hoy this device worked for 6-7 months losing 1-3 packets day, and now it loses around 50 every day.

Could it be that server is wrongly calculating ADR or TX Power for device? Could it be solved if we upgrade server?

This exect behavior can be seen in around 200 nodes.

Hello again.

We kept investigating this behaviour and found that it seems ADR motor is not working properly, it does not seem a server bug, but we don’t know why it is not working for us.

I’ll try to explain what we tested.

First set MAX ADR to 0, this way devices go all the way to DR0 again, kept this configuration during 3~4 days.
Set again normal DR (we use MAX DR3, as we are using loraserver for flowmeters and usually they are behind elevators)
Set installation margin to ~40, this way the server is not optimistic (this has worked for us in the past)

And here is what the strangest thing occurs, the server sets DR3 to all devices again first message. It does not wait.

@brocaar is there any way to reset the ADR motor? Deleting something in the DB maybe? Upgrading to version 3 would help?

As I understand if we change installation margin the loraserver would not lower the DR, right?

Thanks, we will keep investigating, as I said before it does not seem a loraserver bug it seems that something went wrong while upgrading to 2.7.0

There was an ADR related bug which was fixed last Friday and I’m currently creating both a v2 and v3 bugfix release. This bug has been introduced while cleaning up some internal code. Sorry about that. This might be related to your issue.


Thanks for the answer. Will keep track of this and will post again if we see that server improves

Could you test again with LoRa Server v2.8.2 (or v3.0.1)?

Will be testing today.


1 Like

Good news.

After 2 days of testing it seems that the problem is gone and ADR is acting the way it should. Still being a little cautious but we have seen improvements.

If something more happens I will post it here again.


1 Like

Thanks for testing and good to hear this fix might have solved your issue :slight_smile: