How Do I import the device repository after cloning it in docker

Hello,

Just trying to import the TTN device profile templates and followed the instructions and have cloned the repository but I’m unsure of how to execute the import in docker CLI?

git clone GitHub - brocaar/lorawan-devices: Device Repository for LoRaWAN devices /opt/lorawan-devices

Thanks

I have the same issue but to start from something: Helium chirpstack run under Docker so you need to find the process id first. Run docker ps and copy the id of the chirpstack process. It will be something like 7ea9a7b083a2. Copy that and paste it as the in the following command:

docker exec -it chirpstack -c /etc/chirpstack import-legacy-lorawan-devices-repository -d /opt/lorawan-devices

This will execute the chirpstack command under docker.
The problem here is that the dirs are not the right ones for the helium installation and I still haven’t managed to find the right ones. If you find them (or find another workaround) please let me know.
Regards,
Angelo

Hi Angelo,

I have been trying all sort of ways to import this into Chirpstack with No Success yet. Thanks for your command I have tried this a lot of times before but I get the error:

“OCI runtime exec failed: exec failed: unable to start container process: exec: “-c”: executable file not found in $PATH: unknown”

The dir /etc/chirpstack didn’t exist, I tried making dir to see if that would help but unfortunately it didn’t.

sudo mkdir /etc/chirpstack

Yeah, I’ll definitely let you know if I find a way.
Thanks
Adam

Angelo,

I also installed the ‘make’ command and tried this also but didn’t work either

sudo yum install make

make import-lorawan-devices

https://www.chirpstack.io/docs/getting-started/docker.html

Thanks Adam

Hello @brocaar ,

Are you able to please help with importing the LoRaWAN Device Repository Template into ChirpStack in docker?

I have uploaded the Repository into my instance and I can see it in /opt/lorawan-devices

image

Kind Regards
Adam

Please see this command: https://github.com/chirpstack/chirpstack-docker/blob/master/Makefile#L1.

Or you could run chirpstack --help for all the CLI arguments.

1 Like

Thank you @brocaar, I’ll get to it soon and have a look. :slightly_smiling_face:

Thanks @brocaar, went to chirpstack-docker, changed Makefile to what you had as a command in the Makefile and it worked! @abrous3d

  • nano Makefile

  • saved the new command

docker-compose run --rm --entrypoint sh --user root chirpstack -c ’
apk add --no-cache git &&
git clone GitHub - brocaar/lorawan-devices: Device Repository for LoRaWAN devices /tmp/lorawan-devices &&
chirpstack -c /etc/chirpstack import-legacy-lorawan-devices-repository -d /tmp/lorawan-devices’

  • I logged in as root user and then

  • make import-lorawan-devices

Hi Brocaar,

I’m getting some errors with "error 2 "on certain vendors on the import of devices. Do you know what I can do to try and fix this?

I realize that some vendors are listed ONLY within the /vendor/index.yaml in the github repository and do not have any files associated to them hence the error but some do. So is this something the Vendors need to fix with TTN, update their respective devices and Re-compile?

If I look at ‘Axioma’ For example (which has a directory - it looks like the path is incorrect to find the index.yaml for this example with preceeding “jsc-…”)

“2023-12-27T23:59:42.495638Z INFO chirpstack::cmd::import_legacy_lorawan_devices_repository: Found vendor vendor_id=jsc-axioma vendor_name=JSC Axioma Metering
2023-12-27T23:59:42.495644Z INFO chirpstack::cmd::import_legacy_lorawan_devices_repository: Reading devices index file path=”/tmp/lorawan-devices/vendor/jsc-axioma/index.yaml"
2023-12-27T23:59:42.495654Z WARN chirpstack::cmd::import_legacy_lorawan_devices_repository: Failed opening index.yaml within vendor folder, it might not have any devices path=“/tmp/lorawan-devices/vendor/jsc-axioma/index.yaml” error=No such file or directory (os error 2)"

When i go into /opt/lorawan-devices/vendor I can see ‘Axioma’ in there and the index.yaml points towards qalcosonic-w1.yaml (which has Information in it) so I’m not sure why the error is being thrown up? any ideas?

Thanks :slightly_smiling_face: