How to add gateways from different vendors to Gateway OS "Setup LoRa concentrator shield"?

Hi everyone:

I tried to add gateways from different vendors in Gateway OS.
I have an HT-M01 868Mhz and it looks like it is working fine on the OS.

But it can’t be selected directly in the Setup LoRa concentrator shield
of sudo gateway-config, I don’t know how to add my gateway options to the UI of sudo gateway-config.
How can I do this?

Thank you for answering me.

Hi @Saber, I Kinda have the same issue. I have an Arduino Pro LoRa Gateway, and I’m planning on installing the Gateway OS to it. However, it is not listed in the setup of the shield, just like you showed.
Also, did it go smoothly to install the Gateway OS to your shield? Did you have make any special changes?
I would really appreciate your feedback. Thank you!

The HT-M01 is a picoLoRaGateway module that connects to RPI3B via SPI, so my Gateway OS is installed on RPI3B, so I didn’t make any special changes.
If I can select it in the Setup LoRa concentrator shield,
it will make me feel very cool :smiley: ,but it seems that we can’t do it.:persevere:

Thanks for the answer! My Arduino gateway uses an emb-lr1301-mpcle module also connect via SPI to the RPI3B+, so, I’ll give it a try.
And I agree with you, it would be awesome if we could setup or gateways using the option available in Gateway OS…

What matters is primarily the host (pi) pin used for the concentrator reset, and its polarity. The second could vary because the polarity of reset on the SX130x chip is opposite that of mPCIe, and cards using the mPCIe form factor might pick either solution.

In theory you could also have a choice of the host pin used for SPI chip select.

And some hardware may be restricted to slower SPI clock speeds than other.

1 Like

Thank you @cstratton! I’ll keep that in mind. My issue is actually that I bought an Arduino Pro LoRa gateway intending to use it with the lora server but after contacting Arduino, they told me it was not possible to configure the packet forwarder that comes in the gateway (note that now in the page of the product there is a disclaimer in the bottom, which was added after my complaint). So, I’ll try to install the Gateway OS in an SD card e hope that it will work (I know it is risky, but right now that is the only thing I can do).

Thank you once again for the reply!

The most likely case is that they just don’t want to deal with support requests for alternative uses. In all likelihood they’ve got a thinly customized build of the Semtech forwarder or known derivative taking the standard configuration files like global_conf.json

But to start over from upstream sources probably all you really need to do is to figure out what pin and polarity they are using for reset. If you can get a root shell on the pi you can likely find and examine their scripts, or maybe they leave the gpio exported.

So, I’ll try to install the Gateway OS in an SD card e hope that it will work (I know it is risky, but right now that is the only thing I can do).

It’s not all that risky if you install it on another card.

But it’s also not your only choice: if it works, great. But all the various DIY guidance for using random concentrator cards on a pi for TTN etc should be applicable in the basics - ie, look up stuff on iC880A, RAK831, RAK833 in SPI mode, grafting a multitech card onto a pi, etc.

I tried to root on the pi, but I couldn’t (I guess Arduino disabled it). Meanwhile I’ll take a look at the DIY you mentioned. Thanks once again for the comments, they are very helpful.

Clone the card, mount it in another linux box and edit /etc/shadow and /etc/sudoers

Or just poke around without it running and see what is there.

You could even use a raspbian card in the pi to do this, just put Arduino’s card in a USB card reader.

It’s really sad when a company originating in open source makes closed stuff - almost all of their products have posted schematics, but there doesn’t even seem to be one of the carrier board for this, nevermind the mPCIe concentrator card itself.

This list is defined in this repository:, more specifically

The script is quite modular, so it should be fairly easy to add new options. Contributions are appreciated :slight_smile:


Thanks for your tips! It worked! I managed to access the files on the SD card that came with the Arduino gateway, and I could see how they are resetting the SPI before starting the packet forwarder. Now I have an Arduino Gateway working with the Chirpstack Gateway OS :slight_smile:

However, I’m facing problems with the gateway bridge, but I’ll post my question regarding this issue to the right category.

Thanks once again @cstratton!!!

@Nibia oh, it’s exactly what i’m trying to do (update de Arduino pro gateway to use it with chirp or ttn). To help me in this process, could you give me the steps you’ve made?

Thanks a lot in advance et best regards,


Hi David. Send me your email address and I’ll send everything to you, as there are quite a bunch os steps to follow, and I can also send you the scripts for reseting the board, and the configuration file. The way I did I’m using the gateway bridge in the gateway, so that’s the one I have working now.


Hi again,

Thanks a lot for your response and your help! Here is my email address:


If you would be able to share the information on the forum too or putting your script in a GitHub repository, then that could be helpful to others too :slight_smile: