How to connect gateway-os-base to Gateway Bridge on different server

I installed gateway-os-base on RPi with iC880A shield. I also installed Gateway-Bridge with network and application-server on different server. They both are at the same subnet. I want to define gateway-bridge IP and ports in gateway-os but through gateway-config i couldn’t find anything. In which file and how should I define gateway-bridge?

The ChirpStack Gateway OS uses Concentratord, which should run on the same machine / device as the ChirpStack Gateway Bridge. What you probably want to do is update the Gateway Bridge configuration so that it connects to a different MQTT broker.

In the gateway-config command, there is an option to update the Gateway Bridge config. Or else you can manually edit it, the location is /etc/chirpstack-gateway-bridge/chirpstack-gateway-bridge.toml.

1 Like

Hi, I’m having the same trouble that mbayat.

I have Gateway OS Base (raspberry+RAK2245) and I want to connect it to a server (chirpstack) on a different machine of the same network. I want to do that communication over TCP/IP, should I install something like “Semtech UDP packet forwarder” or if I just configure the MQTT broker ( chirpstack-gateway-bridge.toml) the communication is over TCP/IP?


I think I gave the answer already in my previous response :wink: The only think you need to do is configure the MQTT broker to which the ChirpStack Gateway Bridge connects.

I did it several times. when I use sudo monit summary Concentratord is in Initializing mode but other services are OK. I restarted Concentratord in gateway-config but it is in this mode.

What should I check or what reports can I send here for more detail?

I installed again gateway-os-full on my raspberry pi, without any configuration I attached sudo monit summary results.

I seem to have more luck using the RAK software on my pi with the semtech udp for the 2245 rather then the chirpstack OS mqtt using concentratord. Not sure why, i might try latest version again and make sure I didn’t miss configure something.

A little hack you could try, use rak software and setup the gateway with sudo gateway-config and fill in for details for your GW, then chose TTN -> once done go edit the global.json to point the UDP to your chirpstack ns UDP rather then the TTN router/port update with your ipaddress/domain and port by editing and saving that file. Restart pi and you should be good.

Using the RAK software…


head down to bottom of file, in the last block…

"gateway_conf": {
                "gateway_ID": "0000000000000000",
                /* change with default server address/ports, or overwrite in local_conf.json */
                "server_address": "< YOUR IP/DOMAIN HERE >",
                "serv_port_up": <UDP PORT>,
                "serv_port_down": <UDP PORT>,
                /* adjust the following parameters for your network */
                "keepalive_interval": 10,
                "stat_interval": 30,
                "push_timeout_ms": 100,
                /* forward only valid packets */
                "forward_crc_valid": true,
                "forward_crc_error": false,
                "forward_crc_disabled": false,
                /* gps enable */
                "gps_tty_path": "/dev/ttyAMA0",
                "fake_gps": false,
                "ref_latitude": 10,
                "ref_longitude": 20,
                "ref_altitude": -1,
                "autoquit_threshold": 20

Can I use Rak software with my ic880 shield on raspberrypi . Could you pls send RAK software link ?

here actually, there is a lot more information about the rak2245 here using both ttn and chirpstack… have a good read.

RAK downloads for 2245 pi-hat

Sorry i’m unfamiliar with this product ic880, maybe someone else can help you with it.

1 Like