How to Install lora server in RedHat

I want to install lora server in Redhat Linux. I have downloaded the precompiled binary but I am very new to Redhat , so I need installation steps for LoraServer in RedHat.
@brocaar please help

Sorry, I don’t have much experience with RedHat. If you get it all working, a pull request with instructions would be welcome :slight_smile:

Other than Ubuntu / Derbian have you installed it in any other OS using any of the precompiled binaries @brocaar

Yes, I’m running the full stack on MacOS for development. It should all work fine under RedHat but it might require different commands to set everything up (+ package naming for requirements might be slightly different) + you have to create your own SystemD script (you can take the base from the packaging folder from each repository.

Hi @brocaar I tried to install lora server and lora app server using precompiled binary in RHEL.
I configured both .toml files
I tried ./loraserver to start LoraServer and following is the output

_*root@hpe-iotsgf LoRa]# ./loraserver_

_ INFO[0000] starting LoRa Server band=EU_863_870 docs=β€œhttps://docs.loraserver.io/” net_id=010203 version=0.26.0_
_ INFO[0000] setup redis connection pool url=β€œredis://localhost:6379”_
_ INFO[0000] connecting to postgresql_
_ INFO[0000] backend/gateway: TLS config is empty_
_ INFO[0000] backend/gateway: connecting to mqtt broker server=β€œtcp://xx.xx.xx.xx:1883”_
_ INFO[0000] configuring join-server client ca_cert= server=β€œhttp://localhost:8003” tls_cert= tls_key=_
_ INFO[0000] no network-controller configured_
_ INFO[0000] applying database migrations_
_ INFO[0000] backend/gateway: connected to mqtt server_
_ INFO[0000] backend/gateway: subscribing to rx topic qos=0 topic=gateway/+/rx_
_ INFO[0000] backend/gateway: subscribing to stats topic qos=0 topic=gateway/+/stats_
_ INFO[0000] migrations applied count=0_
_ INFO[0000] starting api server bind=β€œ0.0.0.0:8000” ca-cert= tls-cert= tls-key=_
_ INFO[0000] starting downlink device-queue scheduler_

AND LoRa App server using ./lora-app-server
and got following output

[root@hpe-iotsgf LoRa]# ./lora-app-server
INFO[0000] starting LoRa App Server docs=β€œhttps://docs.loraserver.io/” version=0.20.0
INFO[0000] connecting to postgresql
INFO[0000] setup redis connection pool
INFO[0000] handler/mqtt: TLS config is empty
INFO[0000] handler/mqtt: connecting to mqtt broker server=β€œtcp://xx.xx.xx.xx:1883”
INFO[0000] handler/mqtt: connected to mqtt broker
INFO[0000] handler/mqtt: subscribing to tx topic qos=0 topic=application/+/node/+/tx
INFO[0000] applying database migrations
INFO[0000] migrations applied count=0
INFO[0000] starting application-server api bind=β€œ0.0.0.0:8001” ca-cert= tls-cert= tls-key=
INFO[0000] starting join-server api bind=β€œ0.0.0.0:8003” ca_cert= tls_cert= tls_key=
INFO[0000] starting client api server bind=β€œ0.0.0.0:8080” tls-cert=/root/LoRa/cert.pem tls-key=/root/LoRa/key.pem
INFO[0000] registering rest api handler and documentation endpoint path=/api

But I am not able to see anything as UI using https://localhost:8080.

Can you guide me in this issue

I found out the issue. It was related to self signed certificate that I am using for application_server.external_api.tls_cert and application_server.external_api.tls_key
.When I do a Wget https:XXX.X.XXX.XX:8080
I get error like
ERROR: cannot verify XX.X.XXX.XX’s certificate, issued by β€œ/C=IN/ST=KARNATAKA/L=BENGALURU/O=XXXXXX XXX/OU=CMS/CN=XX.X.XXX.XX/emailAddress=XXXXX.XXXX@XX.XX”:
_ Self-signed certificate encountered._

So I need the get the certificate and key for application_server.external_api.tls_cert and application_server.external_api.tls_key respectively.
So @brocaar please let me know how can I generate that

For a free TLS certificate, please see https://letsencrypt.org. There are also many other companies where you can buy one for a couple of dollars.

Thanks @brocaar .My certificates were correct but the port( 8080) was not open.
Any way finally I was able to install loraserver and loraappserver using precompiled binaries i RHEL.
We can close this thread.

1 Like

I try to install loraserver on CentOS 7. Can anyone point me the equivalent instruction for the following used for Ubuntu. Thanks.

Setup LoRa Server software repository
LoRa Server provides a repository that is compatible with the Ubuntu apt package system.

Set up the key for this new repository:

sudo apt-key adv --keyserver keyserver.ubuntu.com --recv-keys 1CE2AFD36DBCCA00
Add the repository to the repository list by creating a new file:

sudo echo β€œdeb https://artifacts.loraserver.io/packages/1.x/deb stable main” | sudo tee /etc/apt/sources.list.d/loraserver.list
Update the apt system:

sudo apt update

I hope you can ignore this step as in CentoS we use precompiled binaries

Hi,

see here I did a guide out for Centos 7.
https://forum.loraserver.io/t/lora-server-installation-on-centos/1256

1 Like