How to permanent storage session infomation after OTAA activated

Hi, all
i install and config my loraserver as, and other lora end-node sensors can join in by OTAA and work fine.
But when i tun off my lorasever and power-off the host server, and then re-power-off host server and start my lorasever, lora end-node sensors can’t upstream to lora server.
There is none valid session information at /Application/app1/Devices/dev1/ACTIVATION in my lorasever‘s config web(http://hostname:8088/#/organizations/1/applications/1/devices/e393000010ffffff/activation), excepted this message “This device has not (yet) been activated.”

I got the below log info in loraserver:
INFO[0087] gateway: rxpk packet received addr=“” data=“QC6H5gHAEAMI2NDL2SVvn6Tq34fbf4S04yDtTv5Mbq/OsObtGtI=” mac=1234567890abcdef
INFO[0087] backend: publishing packet qos=0 topic=gateway/1234567890abcdef/rx
INFO[0087] gateway/mqtt: uplink frame received
ERRO[0087] processing uplink frame error data_base64=“QC6H5gHAEAMI2NDL2SVvn6Tq34fbf4S04yDtTv5Mbq/OsObtGtI=” error=“get device-session error: device-session does not exist or invalid fcnt or mic”
I had try to uncheck “Disable frame-counter validation”, but the situation remained.

if i turn off the end-node sensors and re-power-on , every work fine.

i think the reason is the session information in /Application/app1/Devices/dev1/ACTIVATION after end-node OTAA jioned was not saved to permanent storage database.

How should I deal with it?
Any suggestion is appreciated.

Activation keys are stored in Redis. Make sure you are persisting your Redis data.

hi, bconway
thinks for your suggestions, i will try it.