How to show the web page for setting OTAA information

Hi. I want to use OTAA.

But I can’t find page for setting OTAA parameters like as APPEUI, APPKEY,
How can I use like this page?
( I used latest loraserver and lora-app-server on GitHub)


In my lora-app-server, I can just show as below page. It doesn’t have page to generate or set APPEUI and APPKEY.

The last screenshot shows the page where you enter the appkey :slight_smile: There is no need to enter the AppEUI / JoinEUI.

Hi @brocaar.

Thank you for your fast reply.
As I know, Device has to set AppEUI and AppKey for using OTAA. If there is no need to enter the AppEUI, there is no join-server in the Lora-server or Lora-app-server? It means that I have to use external join-server for OTAA?

When I tried to join to Lora-server using my device, It seems that Lora-server doesn’t reply “Join Accept” to lora device.

This is log in the Lora-app-server. If lora-server or lora-app-server has join-server, Is it right what I did set to device? ( I used AppEUI “0000000000000001” in my device )
In this case, Does it has problem?

LoRa Server will (for now) always act as a default join-server. Please note that the choice of join-server is not decided by what you would provide in LoRa App Server, but by what JoinEUI / AppEUI your device provides on a join-request.

I don’t know why your join-request is not followed up by a join-accept, for this please consult the logs.

Thank you for your opinon.

When I’m debugging for this issue, I found this error log message. Can I get information for this error message?
This is my lora-server’s log message when I tried to join using my device.

INFO[0089] backend/gateway: rx packet received
INFO[0089] backend/gateway: rx packet received
INFO[0089] packet(s) collected dev_eui=0008dcfffe000001 gw_count=1 gw_macs=b827ebfffea7fb4d mtype=JoinRequest
ERRO[0089] processing rx packet error: join-request to join-server error: http post error: Post http://localhost:8003: net/http: HTTP/1.x transport connection broken: malformed HTTP response “\x15\x03\x01\x00\x02\x02\x16” data_base64=“AAEAAAAAAAAAAQAA/v/cCACaVILx5ho=”

Hi~ @brocaar

Thank you for your help. I solved this problem.
There is some problem in my tls configuration of lora-server and lora-app-server.

After I don’t use tls option at join_server, My device can be successed to OTAA join.

Thank you.^^

1 Like