How to use a Pine A64 (Quad core ARM, 64 bit) as a LoRa Server?

Recently, today, we installed Debian LXDE (3.10.102 BSP 2) , on our Pine A64, and then made attempts to install The Lora Server Project, on this combination using the command,sudo apt install mosquitto mosquitto-clients redis-server redis-tools postgresql.

That failed with, unable to fetch, and error 404 errors.

So, we tried again with, Debian Mate (3.10.102 BSP 2) and got the same failure, and then tried again with, Ubuntu Base Longsleep (3.10.65 BSP) and discovered there was no desktop in that release.

So, I am posing the question, is there something special we need to do to make The Lora Server Project install on our Pine A64 module running Debian?

As a development platform, the very small size seems like such a great fit for learning.

I appreciate any and all insights you may have towards this problem.

In case it’s worth noting, I had set up the Pine with a static address and I had no problem pinging, as was one of my nameserver entries.

I thank you in advance

Did you do an apt update before the apt install (the apt cache could be outdated, pointing to links that do not exist anymore)? If that does not work, could you post the actual error messages?

I used the Synaptic package manager to perform the install of the various components of mosquitto, mosquitto-client, etc…
I just read that Synaptic does an update when you start it up, would that qualify as a yes or no to your update question?
Further, if the package is listed in the synaptic GUI, would that not mean that the package exists and is up to date?
I’m sorry, Linux is extremely new to me, I am very ignorant in this area.
I will review this again on Monday.

I would suggest to perform the install from the cli, as the Gui of the package manager might be hiding the actual error.

I will try that Monday and hopefully success, or, switch to a Intel based Linux, they typically work I’m told.

OK, I ran the apt update, nothing to update.

sudo apt install mosquitto mosquitto-clients results in numerous errors,

W: Failed to fetch
404 Not found [IP 80]

I suppose that means that the creator of the Debian release for the Pine A64 a quad core ARM 64 bit chip did not compile all of the varios packages for the hardware platform. Is that a correct assumption?
If that is the case, then how complex is it to do the work to make the various packages for the platform, is that something a person (me) with next to know Linux knowledge could do?

I don’t know how complex this is. But before solving the issue yourself, why not post this error on the Pine A64 forum / mailinglist? Maybe there are more users experiencing this issue. Solving the issue at the root is better than that everybody tries to apply his / her on fix :slight_smile:

I have reached out the person that is doing the Linux ports for them, we’ll see what happens.