HTTPS integration x509 error

Hi!, I’m a quite newbie in LoRaWAN. First of all, thank you for this awesome work! and I apologize for my English, it’s not very good :anguished:

I’ve tried to use the http integration to send device uplink data to my server. But our serve uses https, so the configured URL is something like https://…

When POST is done I’ve obtained the following error: appserver_1 | time=“2020-05-21T06:49:10Z” level=error msg=“integration/multi: integration error” ctx_id=19ac6cfa-d5fd-4013-96c9-85b3daf5be12 error=“send error: http request error: Post https://…my server…: x509: certificate signed by unknown authority” integration="*http.Integration"

How can I solve this issue?

I’ve also read and I’ve generated them successfully, but I don’t know what .toml configuration file has to be used to set these certificates (which one must be used, what section has to be used…)

I’ve also test to use a bin from, and then no error is returned and I’m able to see in the bin the POST information… I don’t understand…

I’m sorry if this issue is solved somewhere in the forum and perhaps it’s a too basic issue.

Can anyone help me?

Thank you in advance for your help.

Any solution, please?

Thank you

Use a certificate that is signed by a trusted certificate :slight_smile:

Hello, brocaar

Thank you for your reply.

I think this certificate has to be set in the chirpstack-application-server.toml configuration file, is it that correct? and what section/item has to be used?

I’m sorry because it’s possible my questions are too basic.

Thank you for your help.

This is not possible. When it is a TLS certificate for a public domainname, then you could use for example An other way is to add your self-signed certificate to the trusted certificates of your OS.

This could be helpful: