Is connector board for RAK2287 supported?

I flashed on RAK Hotspot V2: Raspberry Pi 4 + RAK2287

If I enable connector board I get a looping error:

Tue Jul  2 20:33:29 2024 user.info chirpstack-concentratord-sx1302[2947]: Starting the concentrator
Tue Jul  2 20:33:34 2024 user.info chirpstack-concentratord-sx1302[2954]: Starting Concentratord SX1302 (version: 4.4.1, docs: https://www.chirpstack.io/docs/chirpstack-concentratord/)
Tue Jul  2 20:33:34 2024 user.info chirpstack-concentratord-sx1302[2954]: Setting i2c device path, path: /dev/i2c-1
Tue Jul  2 20:33:34 2024 user.info chirpstack-concentratord-sx1302[2954]: Setting board configuration, lorawan_public: true, clock_source: 0, com_type: Usb, com_path: /dev/ttyACM0
Tue Jul  2 20:33:34 2024 user.info chirpstack-concentratord-sx1302[2954]: Setting up fine timestamp, enable: false
Tue Jul  2 20:33:34 2024 user.info chirpstack-concentratord-sx1302[2954]: Setting up concentrator channels
Tue Jul  2 20:33:34 2024 user.info chirpstack-concentratord-sx1302[2954]: Configuring radio, radio: 0, enabled: true, center_freq: 867500000, type: SX1250
Tue Jul  2 20:33:34 2024 user.info chirpstack-concentratord-sx1302[2954]: Configuring radio, radio: 1, enabled: true, center_freq: 868500000, type: SX1250
Tue Jul  2 20:33:34 2024 user.info chirpstack-concentratord-sx1302[2954]: Setting up concentrator channels
Tue Jul  2 20:33:34 2024 user.info chirpstack-concentratord-sx1302[2954]: Configuring multi-SF LoRa channel, channel: 0, enabled: true, freq: 868100000, rf_chain: 1, if_freq: -400000
Tue Jul  2 20:33:34 2024 user.info chirpstack-concentratord-sx1302[2954]: Configuring multi-SF LoRa channel, channel: 1, enabled: true, freq: 868300000, rf_chain: 1, if_freq: -200000
Tue Jul  2 20:33:34 2024 user.info chirpstack-concentratord-sx1302[2954]: Configuring multi-SF LoRa channel, channel: 2, enabled: true, freq: 868500000, rf_chain: 1, if_freq: 0
Tue Jul  2 20:33:34 2024 user.info chirpstack-concentratord-sx1302[2954]: Configuring multi-SF LoRa channel, channel: 3, enabled: true, freq: 867100000, rf_chain: 0, if_freq: -400000
Tue Jul  2 20:33:34 2024 user.info chirpstack-concentratord-sx1302[2954]: Configuring multi-SF LoRa channel, channel: 4, enabled: true, freq: 867300000, rf_chain: 0, if_freq: -200000
Tue Jul  2 20:33:34 2024 user.info chirpstack-concentratord-sx1302[2954]: Configuring multi-SF LoRa channel, channel: 5, enabled: true, freq: 867500000, rf_chain: 0, if_freq: 0
Tue Jul  2 20:33:34 2024 user.info chirpstack-concentratord-sx1302[2954]: Configuring multi-SF LoRa channel, channel: 6, enabled: true, freq: 867700000, rf_chain: 0, if_freq: 200000
Tue Jul  2 20:33:34 2024 user.info chirpstack-concentratord-sx1302[2954]: Configuring multi-SF LoRa channel, channel: 7, enabled: true, freq: 867900000, rf_chain: 0, if_freq: 400000
Tue Jul  2 20:33:34 2024 user.info chirpstack-concentratord-sx1302[2954]: Configuring Std LoRa channel, enabled: true, freq: 868300000, rf_chain: 1, if_freq: -200000
Tue Jul  2 20:33:34 2024 user.info chirpstack-concentratord-sx1302[2954]: Configuring FSK channel, enabled: true, freq: 868800000, rf_chain: 1, if_freq: 300000
Tue Jul  2 20:33:34 2024 user.info chirpstack-concentratord-sx1302[2954]: Starting the concentrator

Module should be supported. Have I misconfigured something?

I did some poking around and it gets into this connector board reastablishing loop after:

Fri Jul  5 19:55:05 2024 daemon.err postmaster[1199]: 2024-07-05 16:55:05.018 UTC [2] LOG:  checkpoint starting: time
Fri Jul  5 19:55:05 2024 daemon.err postmaster[1199]: 2024-07-05 16:55:05.145 UTC [2] LOG:  checkpoint complete: wrote 2 buffers (0.0%); 0 WAL file(s) added, 0 removed, 0 recycled; write=0.105 s, sync=0.006 s, total=0.128 s; sync files=2, longest=0.004 s, average=0.003 s; distance=1 kB, estimate=1 kB

Then even after a reboot I get into the loop and more errors:

Fri Jul  5 19:53:13 2024 kern.err kernel: [    0.292556] bcm2708_fb soc:fb: Unable to determine number of FBs. Disabling driver.
Fri Jul  5 19:53:13 2024 kern.warn kernel: [    0.292585] bcm2708_fb: probe of soc:fb failed with error -2
...
Fri Jul  5 19:53:13 2024 user.err kernel: [    3.795612] block: unable to load configuration (fstab: Entry not found)
Fri Jul  5 19:53:13 2024 user.err kernel: [    3.795696] block: no usable configuration
...
Fri Jul  5 19:53:13 2024 user.err kernel: [    3.795612] block: unable to load configuration (fstab: Entry not found)
Fri Jul  5 19:53:13 2024 user.err kernel: [    3.795696] block: no usable configuration
Fri Jul  5 19:53:13 2024 kern.info kernel: [    3.796203] loop0: detected capacity change from 0 to 8388608
Fri Jul  5 19:53:13 2024 kern.info kernel: [    3.852335] loop0: detected capacity change from 8388608 to 8287872
Fri Jul  5 19:53:13 2024 kern.notice kernel: [    4.048646] F2FS-fs (loop0): Mounted with checkpoint version = 5851f4dc
Fri Jul  5 19:53:13 2024 user.info kernel: [    4.067630] block: attempting to load /etc/config/fstab
Fri Jul  5 19:53:13 2024 user.err kernel: [    4.067722] block: unable to load configuration (fstab: Entry not found)
Fri Jul  5 19:53:13 2024 user.err kernel: [    4.067782] block: no usable configuration
Fri Jul  5 19:53:13 2024 user.info kernel: [    4.068843] mount_root: switching to f2fs overlay
Fri Jul  5 19:53:13 2024 user.err kernel: [    4.083660] insmod: module is already loaded - fat
Fri Jul  5 19:53:13 2024 user.err kernel: [    4.085640] insmod: module is already loaded - vfat
Fri Jul  5 19:53:13 2024 kern.warn kernel: [    4.101778] FAT-fs (mmcblk0p1): Volume was not properly unmounted. Some data may be corrupt. Please run fsck.
Fri Jul  5 19:53:13 2024 user.warn kernel: [    4.103636] urandom-seed: Seeding with /etc/urandom.seed
...
Fri Jul  5 19:53:15 2024 daemon.err uwsgi[1253]: [uWSGI] getting INI configuration from /etc/uwsgi/emperor.ini
Fri Jul  5 19:53:15 2024 daemon.err uwsgi[1253]: *** Starting uWSGI 2.0.25.1 (32bit) on [Fri Jul  5 19:53:15 2024] ***
Fri Jul  5 19:53:15 2024 daemon.err uwsgi[1253]: compiled with version: 12.3.0 on 14 November 2023 13:38:11
Fri Jul  5 19:53:15 2024 daemon.err uwsgi[1253]: os: Linux-5.15.137 #0 SMP Tue Nov 14 13:38:11 2023
Fri Jul  5 19:53:15 2024 daemon.err uwsgi[1253]: nodename: chirpstack-b9ca74
Fri Jul  5 19:53:15 2024 daemon.err uwsgi[1253]: machine: armv7l
Fri Jul  5 19:53:15 2024 daemon.err uwsgi[1253]: clock source: unix
Fri Jul  5 19:53:15 2024 daemon.err uwsgi[1253]: pcre jit disabled
Fri Jul  5 19:53:15 2024 daemon.err uwsgi[1253]: detected number of CPU cores: 4
Fri Jul  5 19:53:15 2024 daemon.err uwsgi[1253]: current working directory: /
Fri Jul  5 19:53:15 2024 daemon.err uwsgi[1253]: writing pidfile to /var/run/uwsgi.pid
Fri Jul  5 19:53:15 2024 daemon.err uwsgi[1253]: detected binary path: /usr/sbin/uwsgi
Fri Jul  5 19:53:15 2024 daemon.err uwsgi[1253]: *** starting uWSGI Emperor ***
Fri Jul  5 19:53:15 2024 daemon.err uwsgi[1253]: [uwsgi-emperor] /etc/uwsgi/vassals/luci-cgi_io.ini -> "on demand" instance detected, waiting for connections on socket "/var/run//luci-cgi_io.socket" ...
Fri Jul  5 19:53:15 2024 daemon.err uwsgi[1253]: [uwsgi-emperor] /etc/uwsgi/vassals/luci-webui.ini -> "on demand" instance detected, waiting for connections on socket "/var/run//luci-webui.socket" 
...
Fri Jul  5 19:53:15 2024 daemon.err postmaster[1198]: 2024-07-05 16:53:15.566 UTC [1] LOG:  starting PostgreSQL 15.1 on arm-openwrt-linux-gnu, compiled by arm-openwrt-linux-muslgnueabi-gcc (OpenWrt GCC 12.3.0 r23630-842932a63d) 12.3.0, 32-bit
Fri Jul  5 19:53:15 2024 daemon.err postmaster[1198]: 2024-07-05 16:53:15.566 UTC [1] LOG:  listening on IPv6 address "::1", port 5432
Fri Jul  5 19:53:15 2024 daemon.err postmaster[1198]: 2024-07-05 16:53:15.566 UTC [1] LOG:  listening on IPv4 address "127.0.0.1", port 5432
Fri Jul  5 19:53:15 2024 daemon.err postmaster[1198]: 2024-07-05 16:53:15.568 UTC [1] LOG:  listening on Unix socket "/var/run/postgresql/.s.PGSQL.5432"
...
Fri Jul  5 19:53:15 2024 daemon.err postmaster[1198]: 2024-07-05 16:53:15.795 UTC [4] LOG:  database system was shut down at 2024-07-05 17:05:31 UTC
Fri Jul  5 19:53:15 2024 daemon.err postmaster[1198]: 2024-07-05 16:53:15.834 UTC [1] LOG:  database system is ready to accept connections
...
Fri Jul  5 19:53:18 2024 daemon.err odhcp6c[2660]: Failed to send RS (Address not available)
Fri Jul  5 19:53:18 2024 daemon.notice netifd: lan (2655): udhcpc: broadcasting discover
Fri Jul  5 19:53:18 2024 daemon.err odhcp6c[2660]: Failed to send SOLICIT message to ff02::1:2 (Address not available)
...
Fri Jul  5 19:53:19 2024 daemon.err odhcp6c[2660]: Failed to send SOLICIT message to ff02::1:2 (Address not available)
...
Fri Jul  5 20:10:52 2024 daemon.err postmaster[1198]: 2024-07-05 17:10:52.361 UTC [2] LOG:  checkpoint starting: time
Fri Jul  5 20:10:52 2024 daemon.err postmaster[1198]: 2024-07-05 17:10:52.390 UTC [2] LOG:  checkpoint complete: wrote 3 buffers (0.0%); 0 WAL file(s) added, 0 removed, 0 recycled; write=0.006 s, sync=0.006 s, total=0.030 s; sync files=2, longest=0.003 s, average=0.003 s; distance=0 kB, estimate=0 kB


If I unplug and power up the device the gateway gets online and works… and goes offline again.