Join Failed - could not handle packet: invalid character '\\x00'

Hi all

Today I stared getting the error:

May 06 20:40:46 ip-172-31-30-86 lora-gateway-bridge[4386]: time=“2019-05-06T20:40:46Z” level=error msg=“gateway: could not handle packet: invalid character ‘\x00’ looking for beginning of value” addr=“” data_base64=“Anq/BXB2/wKssv//AA==”

I’m using a Kerlink iFemtoCell gateway. Never get the gateway-bridge configured on gateway before and it worked normaly.

I did I fresh install of network server, application server and server gateway-bridge after starting getting this error this morning.

My node is a simple arduino with a Dragino Shield only to send fixed packets while we develop the main app.

Now, I’m just getting JOIN_FAILED from node and the log above from gateway bridge on server.

I don’t want/need to use gateway bridge, exactly as my first configuration;
I got the latest version of wirnet firmware and packet-forward on my gateway;

here are my frames:

Any help ?

Changing marshaler to “protobuf” actually solved the issue.