Join Reqeust in Broker but device never seen

Hello everyone,
I have a chirpstack server set up in a VM and a gateway configured. After a lot of testing, it now shows up in Chirpstack and not only in my MQTT broker. However, I now have the problem that I can not get the devices added. I added the devices using the OTAA method with the DeviceID and the Application Key. In my MQTT broker I receive the join reqeust but in Chirpstack it shows that the device has never been seen.
Can someone maybe help me with this issue. I have been sitting on this for several weeks now and cannot find the problem.
Any help would be greatly appreciated. If there are any questions or info is still needed I will of course be happy to provide it.
Thanks in advance

And here the MQTT Explorer connected to my Broker

Do you have any JoinAccept? If no JoinAccept, then you need to check again the keys of the nodes.

The steps should be very straight forward.
The links use ChirpStackv4 so it is applicable for you too.

Add a gateway to ChirpStack

Add a node to ChirpStack

I acutally don’t see any LoRaWan Frames in the gateway Tab. But they arrive in my MQTT Broker. What am I doing wrong here

Do you have any web proxy in fromt of ChirpStack?

There should be no proxy.

I found out something new. I testes MSB, LSB order in AppKey as well as in DevEUI. It seems like the order is making no difference. I went into a terminal and looked at the postgres database. The nwkey is beeing generated but the app key is set to 0x000 as you can see in the screenshot. Any suggestions? I am at my wit’s end.

You should check the chirpstack-gateway-broker configuration. In the v4, the chirpstack-gateway-broker settings topic will need a region prefix, for e.g.,

# Integration configuration.
# Payload marshaler.
# This defines how the MQTT payloads are encoded. Valid options are:
# * protobuf:  Protobuf encoding
# * json:      JSON encoding (easier for debugging, but less compact than 'protobuf')

  # MQTT integration configuration.
  # Event topic template.
  event_topic_template="**us915_0**/gateway/{{ .GatewayID }}/event/{{ .EventType }}"

  # Command topic template.
  command_topic_template="**us915_0**/gateway/{{ .GatewayID }}/command/#"

In my configuration, for e.g., I am using us915_0 region.
I had the same issue and resolved it after setting this region.