Join Request Loop

I’m trying to move from TTN to Chirpstack. I started by registering the gateway and everything went well. However, when I want to register the devices and activate them, the problem of “last seen: never” occurs and I’m stuck in the “Join Request Loop”.

For device activation I’m using OTAA, I tried to change and alter the keys as LSB and MSB but nothing works.

Attached you can find a screenshot for the device configuration, device data along with the gateway live frames.
Any help will be highly appreciated.

The screen shots aren’t loading for me.

Keys must not be right. What do you see in the logs for the network and application servers?

How can I check for the logs?

That would depend on how you have the chirpstack deployed. It will be different whether you’re running a service on a Linux VM, or a container in say Kubernetes.

I have it on a Linux machine

There is some guidance on logs in these sections:

okay, I will check them. Thank you

Note that you can expand the error under Applications / iot / Devices / … :wink: That should give you a hit what is wrong. In case you see a MIC error, then it is the AppKey.

1 Like

I read almost all the threads related to my problem, worked on the AppKey and MSB/LSB but nothing worked :neutral_face:.
I’m using mkr wan 1300 arduino board, tried the OTAA but didn’t work (stuck in the JoinRequest loop). Tried the ABP I receive “Unconfirmed Data up” with devAddr different than the one assigned by chirpstack for some time and then it stops.

The screenshot that you shared shows that there are a couple errors. It would be helpful to know what these errors are. If you click on them, it will give you more information that should help you to debug your issue further.

After changing the regional parameters from B to A using MAC version 1.0.2, and after adding the device to applications the activation window where the network session key appears however the application session key is all zeros.

Attached you can find the activation window, application server logs and network server logs.

i have the same problem of join request loop, did you manage to find a solution?

Yes now my server and device both are working fine. What I did is as follows:
1- started the mosquitto
2- started redis server
3- started network server
4- started application server
5- started the gateway bridge
On the gateway side: I’m using the Rak2245 Lora pi hat, I configured the Lora server to chirpstack and entered the IP address of the host machine where I installed the server(in the global_conf.json file) And I used the internal gateway bridge to access the graphical interface of the server, i.e: I entered the ip address of the raspberry pi to access the graphical interface.

the 5 steps are okey for me, i think i have no problem with mosquitto, redis, network server, app server and gateway bridge! i have everything running on my server even the gateway bridge!
i am using dragino lg02 gateway and my end device is lora node phat using rak811!
i still have join request loop, what i think is the network is not sending the join accept to the device or the device is not receiving it!
i appreciate your help

1 Like