Joinrequest Infinity

hello I tried to change all the possible settings but I can’t connect my device to the server

I always get this. it’s probably a trivial thing that I’m wrong. does anyone know how I can solve this problem or have a suggestion? thanks.

then when everything works I create a detailed guide on this forum to list all the problems encountered and their solution

When you see a join-request but no join-accept, this usually means that the join-request is not accepted. Please refer to the (Application Server and / or Network Server) logs for more information. When it tells you that the device was not found, then it means you still need to add the device (e.g. wrong DevEUI), in case you see a MIC failure, then it means the key is incorrect.

1 Like

Thanks for the reply. I wanted to check the logs.

perhaps it seems absurd to you but how do I check the logs on ChirpStackOS? what command do I have to give to see the logs? thanks.

The appKey must be inserted in arduino without empty spaces for example instead of putting “b7 d0 3e f4 c6 86 5b 40 62 fd 0f dd 98 14 83 bb” you must put “b7d03ef4c6865b4062fd0fdd981483bb” and in MSB format.
Furthermore “LoRaWAN MAC version” only goes with 1.0.X with 1.1.0 NOT going.

Hi Fabio, i have the same problem, i only receive “joinrequest” paquet. But i can’t user your solution because i use manufacured devices with AppKey inside.

Any idea? Thanks in advance!

Hi brocaar, in network server log i find this message: error=“join-request to join-server error: http post error: Post http://localhost:1883: read tcp [::1]:49026->[::1]:1883: read: connection reset by peer”

Any idea? Thanks in advance!

I did not understand correctly, the APPKEY is fixed in the devices? Can’t you change it?

I can’t change it. The manufacturer put it inside and then when you buy device, he say you, the AppKey.

Understand me?

1 Like

you can enter the key manually on the server instead of generating one

if you don’t have instructions on lorawan mac version you could do some tests

for example put the key in msb and wan mac version 1.0.1 if it doesn’t work change in lsb
otherwise change wan version 1.1.0 and try again

I advise you to take the tests in otaa not in abp so the key is only 1
as it should which you can put 0 or a series of 0 or leave it empty but I recommend a 0 to avoid problems
I have solved this in the absence of documentation that is understandable for me and so now I have created my documentation.
let me know if you need more help

Solved!, the problem was the port of join-server api. There was different in network-server .toml and application-server.toml.

When i saw this message: Error of TLS Join Server Configuration I understood.


1 Like