Joint request rejected


I’m having a problem with one of my devices not getting a JointAccept massage. everything was working normally and I switched off my Gateway for a few days. When I plugged in my gateway again one of my devices is now having problems to get a JoinAccept massage. I’m getting the following error massage:

  • error:“join-server returned error: response error, code: MICFailed, description: invalid mic”
    I tried to delete the Devnonse but that did not help. I tried to delete the device and create a “new” device but that did not help. Any idea what I can do to solve the problem?


Invalid MIC is not related to the DevNonce but (usually) means that the AppKey does not match with the AppKey configured inside ChirpStack.

1 Like

Thank you Brocaar. The problem started with a DevNonce error and beacuse I had no idea what caused the initial problem also I reset the device. This reset changed the DevEUI and i was not aware of it. After correcting the DevEUI everything is working again.