Joning failed, device is not actived (OTTA) with CN470 configuration

I was stucked on getting device joined. There is not activation appeared on management web page, either no ACK message in the log.

Here is my case:
I installed the chirpstack full version OS on raspberry pi3, with the concentrator of RXHF-RHF0M301-470. I setup as below:.

  1. concentratord: I select the shield of RXHF-RHF0M301 → EU868 (since there is no CN470 option) in gateway-config platform
  2. I modified toml files of “chirpstack-network-server.toml”, “sx1301/channels.toml”, and “sx1301/global.toml”, as the snapshots.
  3. What I set on the admin webpage are: “LoraWan mac version: 1.0.2”, “OTTA”, application key in MSB, and devEUI in LSB.

When I checked the log file, I found the joining packet is received, but no ack message, I am not so sure if my configuration modifications for CN470 are correct, or somewhere else need to set, Please advise,


CN470 actually has a lot of channels. But since this gateway is an 8-channel gateway, it means that only 8 channels can be used. Have you checked that your LoRa node uses the same 8x channels?

CN470 officially has 8x downlink channels that are different from the uplink channels. Do ensure that your device does this. I have encountered one device that used the same channel for downlink as uplink - which is non-standard.

I do not really understand what you meant by “RXHF-RHF0M301 → EU868”. It must be configured to use CN470, as EU868 doesn’t have the same behaviour.

Thank you for your reply, you raised the exact point I was confused.
I have set up the uplink channels, which are the same with the end node, in sx1301/channels.toml. While I didn’t find any place to set up the downlink channels, so I supposed there is a default setting has been made in the source code somewhere, it is gonna effect as long as I selected “CN470” in “chirpstack-network-server.toml”.

Regarding to what I’v mentioned “shield of RXHF-RHF0M301 → EU868 (since there is no CN470 option)”, it is another doubt of the OS default configurations since there is no CN470 could be chosen originally, which makes me feel unconfident say if my modification is enough and correct, see the snapshot.

I have not used concentratord before. But if it cannot support CN470, then perhaps you should use either Semtech UDP Packet Forwarder or Basic Station.

If you use the Semtech UDP Packet forwarder, the channels are configured in the GW. If you use Basic Station, they are configured from the Network Server.

I see, your suggestion is helpful, I may take a try with UDP packet forwarder then.

Thank you .