Kerlink iFemtoCell

hi, i have updated the kerlink iFemtoCell to firmware 4.3.3_20200803132042, setup an openvpn tunnel (up and running, chirpstack is reachable), install the bridge (https://www.chirpstack.io/gateway-bridge/gateway/kerlink/#kerlink-ifemtocell) and define all configs. at the end, chirpstack never seen the gateway ?! so i’m not realy sure to define or get the right gateway_id?
cat /tmp/board_info.json call me in “EUI64”, is this the gateway_id by default? in /etc/lorafwd.toml can i define an [ gateway ] -> id so i have define an value like this: 0x6a6690518b8c3125 … but all of this isnt helped, chirpstack show me all the time “gateways never seen”… :frowning: firewall is also set by this rule:

# cat /etc/firewall.d/11_chirpstack.rules 
*filter
# ChirpStack ports
-A INPUT  -p tcp -m tcp --sport 1883 -j ACCEPT
-A OUTPUT -p tcp -m tcp --dport 1883 -j ACCEPT
COMMIT

logfiles on iFemtoCell and chirpstack dont show anything what helping me, so no errors… maybe someone can debug this with me?

regards,
volker…

So to debug your Issue:

  1. Subscribe to the gateway topic and check if it’s publishing traffic. For example: gateway/# (subscribe to all gateways and all messages)
  2. The gw_id is probably printed outside of the gateway. Check if it’s the same as you configured.
  3. Check if the network-server is connected and subscribed to the gateway topics -> your MQTT-Server might have a management API, get a list of the clients connected.

Our config files.

/etc/default/lorafwd
# Configuration file for lorafwd.

# Disable lorawd (default value: no)
DISABLE_LORAFWD="no"

# The configuration file.
CONFIGURATION_FILE="/etc/lorafwd.toml"

# The extra arguments.
EXTRA_ARGS="-vv"


/etc/default/lorad
# Configuration file for lorad.

#### Common configurations.

# Disable lorad (default value: no)
DISABLE_LORAD="no"

# The extra arguments.
EXTRA_ARGS="-vv"

# The configuration file.
CONFIGURATION_FILE="/etc/lorad/wifc/EU868-FR.json"

# The FPGA firmware binary file.
FPGA_FIRMWARE_FILE="/usr/share/lorad/fpga_v61.bin"

/etc/lorafwd.toml

[ gwmp ]
node = "127.0.0.1"
service.uplink = 1700
service.downlink = 1700

cool, thx! gateway is now up and running! the missing point was

DISABLE_LORAFWD="no"

and

DISABLE_LORAD="no"

volker…