Kerlink Wirnet iStation SSL certificate issue

Hello Chirpstack Community,

We have a Kerlink Wirnet iStation 868 LoRa gateway and we are currently having issues to configure self-signed TLS/SSL certificates with the Basics Station implementation and Chirpstack 4.8.1.

I did the following:

  • Upgraded the Kerlink Gateway FW to v5.11.0 (shipped with v4.3.3)

  • I downloaded and installed the Basic Station implementation from here

  • I followed the instructions from the Kerlink Wiki page to configure the Basic Station to communicate with Chirpstack

  • The first step was to just verify communication with Chirpstack in LNS mode without any certificates, which worked fine (gateway online in Chirpstack)

  • Thereafter I generated self-signed certificates and redeployed Chirpstack (using the Chirpstack Gateway-Bridge)

  • I then updated the configuration on the Kerlink Gateway itself, but seems as though the certificates are rejected on the Gateway during handshaking

    • I see this error on the Chirpstack Gateway Bridge:
      2024/06/03 13:13:13 http: TLS handshake error from EOF
  • The self-signed certificates work with other LoRa gateways (RAK and Mikrotik), so it seems to be an issue on the Kerlink gateway

  • I also used the following Curl command on the Kerlink Gateway, which worked:

    • $ curl -v --cacert --cert tc.crt --key tc.key --insecure

Does anyone have an idea of what the issue might be?

Thanks in advance.

Best regards,