LoRa App Server REST API uuid error

I am having some problems using the Rest API. I can do GET requests using a JWT token but I am having a problem when I try to do a POST. Every time I POST I get the following error. I am not sure do I need to pass the uuid somehow. I am using the Rest GUI which generates a curl command. The Rest API GUI does not have a space for the uuid so I am not sure why its throwing an error. Is the UUID part of the JWT token? Why this is only happening with POST?

“error”: "uuid: incorrect UUID length: ",
“message”: "uuid: incorrect UUID length: ",
“code”: 2,
“details”: []

Could you share some more details? E.g. which API endpoint are you posting to and what URL arguments / body payload?

Using this call

Trying to create a simple test application.

“application”: {
“description”: “Simple Test”,
“name”: “Test1”

You are missing the serviceProfileID. You must first create a service-profile object before you can create an application.

Ok I see the service Service Profile which I set and used for other applications but its a name not an ID. Is there a way to retrieve its ID? I assume the API wants a unique number. I tried it with the name and it shows the same error below.

  "error": "uuid: incorrect UUID length: Test-Gateway",
  "message": "uuid: incorrect UUID length: Test-Gateway",
  "code": 2,
  "details": []

When you create an object, you’ll find the assigned ID or UUID in the response body. To find out IDs or UUIDs of existing objects you need to use the list endpoint.