Lora gateway bridge: Connection problem to google mqtt

When trying to start the Lora Gatway Bridge and connect to ssl://mqtt.googleapis.com:8883 I recive "ERRO[0010] mqtt: connection error error="Bad user name or password""

Now, Ive set the type to be gcp_cloud_iot_core and specificed the path to my private-key jwt_key_file="/usr/lora/private-key.pem"

Ive tried to connect using this private key from my localmachine, using a node script, and it connects. This is on the same network as the bridge so ssl://mqtt.googleapis.com:8883 is reachable

Now if I try to use a wrong certificate on my local machine, the error message is “not authorized”.

Any ideas what could be wrong? Is it trying to use generic authentication?
Im running the bridge manuall specifying the config using
/opt/lora-gateway-bridge/lora-gateway-bridge -c /var/config/lora-gateway-bridge/lora-gateway-bridge.toml

Please see: https://www.loraserver.io/guides/google-cloud-platform/. It explains how to configure the LoRa Gateway Bridge to connect with GCP MQTT bridge.

That is the setup I have been following.
Just tried to redo the config file incase I messed something up, but it all looks correct according to this guide