Lora Gateway OS not booting with out HDMI or keyboard

I’ve installed the Lora gateway os basic on a Raspberry Pi but it does not seem to boot when there is no HDMI or Keyboard plugged in.
If either one or both are plugged in I can ssh in to the Pi on its static IP. If neither are plugged in either the Pi doesn’t boot or the networking doesn’t start but either way I can’t see the IP. Tried nmap etc…

Any ideas?

I now have the Pi working with a USB wifi dongle attached. The Pi is being used as a wired device so not too much of an issue but it would still be nice to know why this is happening as I will be building some more gateways.

Were you able to resolve it?

I have the same problem . I tried setting to level 3 as default for inittab but it didnt work

I configured the ethernet port, which is how the Pi is connected to the network, no WiFi, and the gateway is booting fine.

sudo connmanctl services

sudo connmanctl config ethernet_6ceceb5cc4c3_cable --ipv4 manual

hi…i have the same problem with “lora-gateway-os-full-raspberrypi3–20190423151801.sdimg” file; probably i will come back to raspbian lite…

Same problem here, using a RPi 3B+ and the RAK2245 hat.

Anyone found a solution to this?

This issue has been reported on GitHub too: https://github.com/brocaar/lora-gateway-os/issues/9.

Until now I’m unable to reproduce this. I have tested with a Raspberry Pi 3B and 3B+.

My Pi (with RAK2245 shield) is only connected to ethernet + original Raspberry Pi power adapter. The SD card is flashed with https://artifacts.loraserver.io/downloads/lora-gateway-os/raspberrypi/raspberrypi3/2.0.0test4/lora-gateway-os-base-raspberrypi3--20190423145941.sdimg.gz without any modifications made.

Afterwards I run (on my laptop which is configured with a network bridge on

sudo nmap -sP
Starting Nmap 7.70 ( https://nmap.org ) at 2019-07-02 17:22 CEST
Nmap scan report for
Host is up (0.00052s latency).
MAC Address: B8:27:EB:1B:7D:BF (Raspberry Pi Foundation)
Nmap scan report for
Host is up.
Nmap done: 256 IP addresses (2 hosts up) scanned in 9.60 seconds

Then I SSH to the returned IP admin@ and I can login.

have same issue with latest version os-base :frowning: I tried
hdmi_force_hotplug=1 in config.txt , but no joy :confused:

raspberry pi 3 B+

It appear to be only the HDMI the issue, as without USB it boot fine, but not without HDMI